summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-15 10:35:05 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-15 10:35:05 +0000
commitd8743547c5c6dab5ebd6812f99608d572e7fac4a (patch)
tree83ed7deb74ca96ee6a5f552903215261391e5a0a /dev-python/ruamel-std-pathlib
parentprofiles: unmask dev-python/ruamel-yaml[test] on formerly unsupported arches (diff)
downloadgentoo-d8743547c5c6dab5ebd6812f99608d572e7fac4a.tar.gz
gentoo-d8743547c5c6dab5ebd6812f99608d572e7fac4a.tar.bz2
gentoo-d8743547c5c6dab5ebd6812f99608d572e7fac4a.zip
dev-python/ruamel-std-pathlib: bump to 0.8.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-std-pathlib')
-rw-r--r--dev-python/ruamel-std-pathlib/Manifest1
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.8.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/ruamel-std-pathlib/Manifest b/dev-python/ruamel-std-pathlib/Manifest
index 1eab82388ebe..a842febd645b 100644
--- a/dev-python/ruamel-std-pathlib/Manifest
+++ b/dev-python/ruamel-std-pathlib/Manifest
@@ -1 +1,2 @@
DIST ruamel-std-pathlib-0.6.4.tar.xz 18844 BLAKE2B 714b38dc832839d9e915f74aa45a7b3e277578e89ed23c55599d598bd3a3de3e8231fb2f3890c60e065d84ae146ca5071305ea0bae750b1a42808a58d0ce1d01 SHA512 079e423d1fa70629429b0af8254a5034ca198b4e131205c3fac87cfb320d6821f3290a457db84550a280db1aa46542a8db81555cfaa3c8143a31515704e5f45e
+DIST ruamel-std-pathlib-0.8.0.tar.xz 19068 BLAKE2B e1709bf5af17a843a7f5aec8009c4ec337cd1a4a526315e8834924909613eb5cc50c2ae1a1acc74c97a876fa347767dce627f2dba1fb874032f0989f7ee6599e SHA512 eecbb43e3867d8ccb166a0d528b3d7cfc04ed6f2df5e2048ccec4d7fd36117ac4a3984d4143025f6b7fd51867de879fe02e5dcbc4b275fd40cab1609bcf69536
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.8.0.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.8.0.ebuild
new file mode 100644
index 000000000000..dcbd6c7752bd
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
+HOMEPAGE="https://pypi.org/project/ruamel.std.pathlib/ https://sourceforge.net/p/ruamel-std-pathlib"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="dev-python/namespace-ruamel[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_P}
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}