summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-06 16:21:05 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-06 16:40:24 -0800
commitd9d668b5c2f664ad5dbdb4ded7f273f6a3e3b7ba (patch)
treef758c036e3aa3b0c3da834429d4d99ef2384a1cc /dev-python/ruamel-std-pathlib
parentcargo.eclass: use verbose cargo invocations (diff)
downloadgentoo-d9d668b5c2f664ad5dbdb4ded7f273f6a3e3b7ba.tar.gz
gentoo-d9d668b5c2f664ad5dbdb4ded7f273f6a3e3b7ba.tar.bz2
gentoo-d9d668b5c2f664ad5dbdb4ded7f273f6a3e3b7ba.zip
dev-python/ruamel-std-pathlib-0.6.4-r1: Revbump, EAPI=7, py38, pypy3
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-std-pathlib')
-rw-r--r--dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4-r1.ebuild b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..b54c2d7e12d9
--- /dev/null
+++ b/dev-python/ruamel-std-pathlib/ruamel-std-pathlib-0.6.4-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7,8} pypy3 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN="${PN//-/.}"
+
+DESCRIPTION="Ruamel enhancements to pathlib and pathlib2"
+HOMEPAGE="https://pypi.org/project/ruamel.std.pathlib/ https://bitbucket.org/ruamel/std.pathlib"
+SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}