summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-02-07 12:09:32 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-02-07 12:12:20 +0000
commitaf34e161939acb123addba00dc65995944bfe006 (patch)
tree6bc0d15f9f4dc4e19d6ea79fa304b2d312e3a468 /dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
parentdev-python/ruamel-std-pathlib: add new package (diff)
downloadgentoo-af34e161939acb123addba00dc65995944bfe006.tar.gz
gentoo-af34e161939acb123addba00dc65995944bfe006.tar.bz2
gentoo-af34e161939acb123addba00dc65995944bfe006.zip
dev-python/ruamel-yaml: add new package
A new dependency of app-misc/khard. Based on work by Foster McLane <fkmclane@gmail.com> Bug: https://bugs.gentoo.org/644994 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild')
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
new file mode 100644
index 000000000000..47cb54173894
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.15.35.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="https://pypi.python.org/pypi/ruamel.yaml https://bitbucket.org/ruamel/yaml"
+MY_PN="${PN//-/.}"
+SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ # This file produced by setup.py breaks finding system-wide installed
+ # ruamel.std.pathlib due to shared namespace
+ rm "${BUILD_DIR}/lib/ruamel/__init__.py" || die
+
+ py.test -v _test/test_*.py || die
+}