summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-09-15 16:19:05 +0200
committerMarek Szuba <marecki@gentoo.org>2021-09-15 16:19:05 +0200
commit7af15a7ec7d33ef5224baa45cf9717840bee6550 (patch)
tree48ada497b77eb6229b0725f58711b572a61244ed /dev-python/ruamel-yaml
parentapp-crypt/yubikey-manager: add 4.0.7 (diff)
downloadgentoo-7af15a7ec7d33ef5224baa45cf9717840bee6550.tar.gz
gentoo-7af15a7ec7d33ef5224baa45cf9717840bee6550.tar.bz2
gentoo-7af15a7ec7d33ef5224baa45cf9717840bee6550.zip
dev-python/ruamel-yaml: drop 0.17.11, 0.17.13, 0.17.14
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest3
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild47
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild47
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.14.ebuild47
4 files changed, 0 insertions, 144 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index d846063a321c..528a1b3abbb3 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,5 +1,2 @@
DIST ruamel-yaml-0.17.10.tar.xz 183116 BLAKE2B 2795f470a3f7da609780109dfac502a5b47184f465c68420f467209275c8857418a4ec7424e130df2e7acef614d93f91551910eceb06cd9e49b365bb23d2a015 SHA512 3cd2598fa37564c44c74720e72babcd2252b2dbcdde626bdcf771b591da5d2852d90bb1f22428e28cd7ec38304be2a437aa0569ffbd3ebb526b2b79a955bc88d
-DIST ruamel.yaml-0.17.11.tar.xz 183476 BLAKE2B 02a1693d3a20f44b7f82668918a53d06f9fa5c0cff6f149fe51de3fbb3551e823f3a7a2f0f4e818f43e2974eaf95c4219d53738bad78544c6bb1f19d85457715 SHA512 8f24b33592c37fd1d370cb6367a3652e72df3d88c7a14fff187aaa8622b9bbd77e780193fcd920916eca7f627dd37c87eb9b987d091c944ff08ef25ee4567b45
-DIST ruamel.yaml-0.17.13.tar.xz 183676 BLAKE2B 7b1be322f99a9cf6b4c5eb9722e4e425641c686574e6bafbed06e094e54ad93ea858c38779bb9f8c4fbc03916fcf7a65c4a3f4514bd8f10c46a8f6d112785350 SHA512 285572292e91702b6ad1e383fdc4f6434297f36ee9949859d2f5a21d23090957d9aabe323f505594fa10dc42822c3384b017c6ea7c3b04633925a291324392a6
-DIST ruamel.yaml-0.17.14.tar.xz 183784 BLAKE2B cc223db89073aa3ba722a8b9a438c118cc4ef2e44f93b3768275776ee5440cbf1de0b1dc4d26ac3c51560c45711df0113076e885e2cc368f542ba02e51608d65 SHA512 5dfd608a79900ec74d570af9af22304d99dce19ce28ed32cb5f53ee71ec31033555da18fb3afe8d52291eb3a6320a91838e9e128047e359f4eea19f6105c76b4
DIST ruamel.yaml-0.17.15.tar.xz 183820 BLAKE2B 901c08d05994a45cb9d8e7071244332c7b3f30fb83f22f9f2f9cfb769ec99ebc39fbdbcf652bc8e7ae8e5b9918aafbc229bcfcbeb1b7d64bd4bed2f8fe0d9ee7 SHA512 cd2fd4d0e2aba1f3f90bd54b355fa603045e913f90c7e460bcc4630619db027b1283af77c613fdc029f48300d8822ca349fb169e30679a1dd86beb1a3f75c49f
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild
deleted file mode 100644
index f87789872e5e..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.11.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild
deleted file mode 100644
index f87789872e5e..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.13.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.14.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.14.ebuild
deleted file mode 100644
index f87789872e5e..000000000000
--- a/dev-python/ruamel-yaml/ruamel-yaml-0.17.14.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-MY_P="${P/-/.}"
-DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
-HOMEPAGE="
- https://pypi.org/project/ruamel.yaml/
- https://sourceforge.net/p/ruamel-yaml/"
-# PyPI tarballs do not include tests
-SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-RDEPEND="
- dev-python/namespace-ruamel[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-# Old PyYAML tests from lib/ require special set-up and are invoked indirectly
-# via test_z_olddata, tell pytest itself to leave the subdir alone.
-python_test() {
- local deselect=()
-
- [[ ${EPYTHON} == pypy3 ]] && deselect+=(
- _test/test_deprecation.py::test_collections_deprecation
- )
-
- epytest --ignore _test/lib/ ${deselect[@]/#/--deselect }
-}
-
-python_install() {
- distutils-r1_python_install --single-version-externally-managed
- find "${ED}" -name '*.pth' -delete || die
-}