summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-02-03 15:21:22 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-02-03 15:21:22 -0600
commit7029f99fd226abf63cc30aa2ec54595a96e55a05 (patch)
tree797b8996e5c16a3e94d2add5e2615f9f6e30310a /dev-python/ryu
parentgnome-extra/mousetweaks: updated Homepage URL (diff)
downloadgentoo-7029f99fd226abf63cc30aa2ec54595a96e55a05.tar.gz
gentoo-7029f99fd226abf63cc30aa2ec54595a96e55a05.tar.bz2
gentoo-7029f99fd226abf63cc30aa2ec54595a96e55a05.zip
dev-python/ryu: fix QA violation
Fixes: https://bugs.gentoo.org/677186 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/ryu')
-rw-r--r--dev-python/ryu/ryu-4.26-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ryu/ryu-4.26-r1.ebuild b/dev-python/ryu/ryu-4.26-r1.ebuild
new file mode 100644
index 000000000000..833a947e96bd
--- /dev/null
+++ b/dev-python/ryu/ryu-4.26-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Component-based Software-defined Networking Framework"
+HOMEPAGE="http://osrg.github.io/ryu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${D}"/usr/etc "${D}"/etc
+}