summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-10 16:00:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-10 16:02:06 +0200
commitb929540acb2a7c73096a03f264f4f5b1e732f8e2 (patch)
tree3aa0eb9c33610955d6b4370b874f8d7e61e45a68 /dev-python/s3transfer
parentdev-python/s3transfer: Port to py3.9 (diff)
downloadgentoo-b929540acb2a7c73096a03f264f4f5b1e732f8e2.tar.gz
gentoo-b929540acb2a7c73096a03f264f4f5b1e732f8e2.tar.bz2
gentoo-b929540acb2a7c73096a03f264f4f5b1e732f8e2.zip
dev-python/s3transfer: Bump to 0.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/s3transfer')
-rw-r--r--dev-python/s3transfer/Manifest1
-rw-r--r--dev-python/s3transfer/files/s3transfer-0.3.3-py38.patch32
-rw-r--r--dev-python/s3transfer/s3transfer-0.3.3.ebuild36
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/s3transfer/Manifest b/dev-python/s3transfer/Manifest
index 2e29d9a6e97b..d3695c154cad 100644
--- a/dev-python/s3transfer/Manifest
+++ b/dev-python/s3transfer/Manifest
@@ -1,2 +1,3 @@
DIST s3transfer-0.2.0.tar.gz 118361 BLAKE2B 0cb0a29e6dfa82762084396db1950a9e1baf4de1d9c8b9f0db3dbf1e274636f60a89ceb959d55cc22fe41c4ce175ab53f414c5c44f08624cc43f0d289f768863 SHA512 2e37a13da67cdabb49deeb177fd9f8d6393128e757e6c9bd93c99eb95a3edbd14736025e284f3173e8247d23239abae3700d894ba0d138f970ceaff748aa6e9e
DIST s3transfer-0.3.1.tar.gz 118716 BLAKE2B 26c25c0eb50b423c08e7ac64e902ab7cbb9e3dcb9cdc7386e6ead17f42ef18bcbb0d60f8334653220f797a03b8a877ae2487de25d8c95344f852d71bb0716408 SHA512 75df6f66d4b0d4a87a88a160cc1c962348331596ae346ebd198fbfb1e1c4d2c216b19627a0600d5a7966d0e683e0a46f6dbae47c9b44bdd65340400f93ed9b3c
+DIST s3transfer-0.3.3.tar.gz 118872 BLAKE2B a8e10a135052a29cbc5949bd8dc82d0b7f76840e6dbc6ba5ccdfe23757d363476f1dc330cee36ceb88e5c5287f644a27ed50b518a346f1b6b8ae38a9ca5576c9 SHA512 e258958b47812d8620ea6ef604dadb2a13beef9bbed005e8d38153039a291099786a3cec68511f2ff4372ff57f60440ca700b6783967484d8284b4ad0c1ae754
diff --git a/dev-python/s3transfer/files/s3transfer-0.3.3-py38.patch b/dev-python/s3transfer/files/s3transfer-0.3.3-py38.patch
new file mode 100644
index 000000000000..89f3d4b5ab32
--- /dev/null
+++ b/dev-python/s3transfer/files/s3transfer-0.3.3-py38.patch
@@ -0,0 +1,32 @@
+From f211b9851698d07cf218e78ebb39a337c8751df8 Mon Sep 17 00:00:00 2001
+From: Christopher Baines <mail@cbaines.net>
+Date: Sat, 2 May 2020 15:19:58 +0100
+Subject: [PATCH] Fix test_download_futures_fail_triggers_shutdown with Python
+ 3.8
+
+The behaviour of set_exception for futures changed in Python 3.8, it'll now
+raise concurrent.futures.InvalidStateError if the future is already done [1],
+which is the case in this test because set_result has already been called on
+the future.
+
+1: https://bugs.python.org/issue33238
+
+Fix the test by not using the future from SequentialExecutor, and instead
+creating a future which doesn't have a result.
+---
+ tests/unit/test_s3transfer.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/unit/test_s3transfer.py b/tests/unit/test_s3transfer.py
+index a87b4dd..4715be2 100644
+--- a/tests/unit/test_s3transfer.py
++++ b/tests/unit/test_s3transfer.py
+@@ -465,7 +465,7 @@ def __init__(self, max_workers):
+ self.is_first = True
+
+ def submit(self, function):
+- future = super(FailedDownloadParts, self).submit(function)
++ future = futures.Future()
+ if self.is_first:
+ # This is the download_parts_thread.
+ future.set_exception(
diff --git a/dev-python/s3transfer/s3transfer-0.3.3.ebuild b/dev-python/s3transfer/s3transfer-0.3.3.ebuild
new file mode 100644
index 000000000000..843a42f09de1
--- /dev/null
+++ b/dev-python/s3transfer/s3transfer-0.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="An Amazon S3 Transfer Manager"
+HOMEPAGE="https://github.com/boto/s3transfer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/botocore[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests nose
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py38.patch
+)
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "tests failed under ${EPYTHON}"
+}