summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-18 21:14:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-18 21:14:45 +0300
commit57ea44b8b8fdc2c57c3f8e0e328d12d2cecb3add (patch)
tree1dcd21e36a48f634d2a63811d110a3cfd571055e /dev-python/sabyenc/sabyenc-4.0.2.ebuild
parentdev-libs/libgcrypt: drop 1.8.6, 1.9.1-r1, 1.9.2, 1.9.3 (diff)
downloadgentoo-57ea44b8b8fdc2c57c3f8e0e328d12d2cecb3add.tar.gz
gentoo-57ea44b8b8fdc2c57c3f8e0e328d12d2cecb3add.tar.bz2
gentoo-57ea44b8b8fdc2c57c3f8e0e328d12d2cecb3add.zip
dev-python/sabyenc: fix segfault, enable py3.10
Closes: https://bugs.gentoo.org/736224 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sabyenc/sabyenc-4.0.2.ebuild')
-rw-r--r--dev-python/sabyenc/sabyenc-4.0.2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/sabyenc/sabyenc-4.0.2.ebuild b/dev-python/sabyenc/sabyenc-4.0.2.ebuild
index f777975da68e..d9536017b50b 100644
--- a/dev-python/sabyenc/sabyenc-4.0.2.ebuild
+++ b/dev-python/sabyenc/sabyenc-4.0.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -13,13 +14,15 @@ SRC_URI="https://github.com/sabnzbd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
-DEPEND="test? (
+BDEPEND="test? (
dev-python/chardet[${PYTHON_USEDEP}]
)"
+DOCS=( CHANGES.md README.md doc/yenc-draft.1.3.txt )
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-segfault.patch"
+)
+
distutils_enable_tests pytest