summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:45:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:28 +0100
commit9e21defd04f22d51f7e27287c92b1faa227e2e53 (patch)
tree6f0a25b8c3c7ee855d3edb481ebba5f1f6f58540 /dev-python/sarge
parentdev-python/rtimulib: Switch to PEP 517 build (diff)
downloadgentoo-9e21defd04f22d51f7e27287c92b1faa227e2e53.tar.gz
gentoo-9e21defd04f22d51f7e27287c92b1faa227e2e53.tar.bz2
gentoo-9e21defd04f22d51f7e27287c92b1faa227e2e53.zip
dev-python/sarge: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sarge')
-rw-r--r--dev-python/sarge/sarge-0.1.7-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sarge/sarge-0.1.7-r1.ebuild b/dev-python/sarge/sarge-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..57cad45bee8e
--- /dev/null
+++ b/dev-python/sarge/sarge-0.1.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="wrapper for subprocess which provides command pipeline functionality"
+HOMEPAGE="
+ https://docs.red-dove.com/sarge/
+ https://pypi.org/project/sarge/
+ https://github.com/vsajip/sarge/
+"
+SRC_URI="
+ https://github.com/vsajip/sarge/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+python_test() {
+ "${EPYTHON}" test_sarge.py -v || die "Tests failed with ${EPYTHON}"
+}