summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/scientificpython
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/scientificpython')
-rw-r--r--dev-python/scientificpython/Manifest3
-rw-r--r--dev-python/scientificpython/files/scientificpython-2.9-mpi.patch40
-rw-r--r--dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch29
-rw-r--r--dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch43
-rw-r--r--dev-python/scientificpython/metadata.xml16
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.1.ebuild84
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.3.ebuild70
-rw-r--r--dev-python/scientificpython/scientificpython-2.9.4.ebuild70
8 files changed, 355 insertions, 0 deletions
diff --git a/dev-python/scientificpython/Manifest b/dev-python/scientificpython/Manifest
new file mode 100644
index 000000000000..a3ffbf9380d5
--- /dev/null
+++ b/dev-python/scientificpython/Manifest
@@ -0,0 +1,3 @@
+DIST ScientificPython-2.9.1.tar.gz 595239 SHA256 b45305b03d8238fe1be74d6bbd5541d452d9705ab15069dcd506d38e137e9c5c SHA512 08c609d9204088fa1f9a2563f5321ed7e248469e44c86b5d5bc56dc3f975854c4e2b266a8e750fbdc858ed58a466487da4fe986c15a077319ab1a73d8e9b0305 WHIRLPOOL b731e0aaac972c118519cea9b9076cb449294c3929b4f7baceda69293a1a5c153952b5e46b54e111d1bcdcb2f1ea05162141c8c1f88d284071a7a341218b730d
+DIST ScientificPython-2.9.3.tar.gz 689431 SHA256 a4dfc55c2ec84a0795b0641e5571b79b25a5ef6d92bbb01e934c298ee34b5bc8 SHA512 8633726c8a05f45ac4262dd52213c2dc10148a03b67364d4e50d57953ca410a596f9ba64ee68d3b058dcdc1e7decab21c8b8e9b58e5ac1cf5049cb4588117fa8 WHIRLPOOL 2a7d47770dd1ec7b6eadc85ebdd10ad40f6f3eca873cfc3f4937fdf678d697ac5947e7af9b8caf866b4fe0efb7a2746e684ff8d5775f4f53aafddaed6d110c23
+DIST ScientificPython-2.9.4.tar.gz 688704 SHA256 c397fedf76500dc4c010785a82204a45ee51a04a54fabfb6142d594de14f8639 SHA512 8bd3ce3ead090832582711c25f7d4c7a5a55642ef9a1e845fb68b4b3dba833ba86baf9c444fd9948ce761a5357dbf388a2c1a860a66ee13fdf1f26d1010cc8c8 WHIRLPOOL 7890b534cffa53f258a5db8aa974805055773dc9be5ee9862e9c66f7c07df52e2abb36cc30a07e9bb9c8ee61183f44336643191f41e757ce31fa63773b0df8de
diff --git a/dev-python/scientificpython/files/scientificpython-2.9-mpi.patch b/dev-python/scientificpython/files/scientificpython-2.9-mpi.patch
new file mode 100644
index 000000000000..3140779c74a9
--- /dev/null
+++ b/dev-python/scientificpython/files/scientificpython-2.9-mpi.patch
@@ -0,0 +1,40 @@
+--- Src/MPI/compile.py
++++ Src/MPI/compile.py
+@@ -4,7 +4,7 @@
+ # Normally nothing needs to be changed below
+ import distutils
+ import distutils.sysconfig
+-import os, sys
++import os, subprocess, sys
+ from Scientific import N
+
+ cfgDict = distutils.sysconfig.get_config_vars()
+@@ -32,16 +32,16 @@
+ items[i] = os.path.join(frameworkdir[0], items[i])
+ linkforshared = ' '.join(items)
+
+-cmd = '%s %s -o mpipython -I%s %s %s -L%s -lpython%s %s %s' % \
+- (mpicompiler,
+- linkforshared,
+- cfgDict['INCLUDEPY'],
+- extra_compile_args,
+- sources,
+- cfgDict['LIBPL'],
+- cfgDict['VERSION'],
+- cfgDict['LIBS'],
+- cfgDict['LIBM'])
++cmd = [mpicompiler]
++cmd.extend(linkforshared.split())
++cmd.extend(os.environ.get("CFLAGS", "").split())
++cmd.extend(os.environ.get("LDFLAGS", "").split())
++cmd.extend(["-o", "mpipython"])
++cmd.extend(["-I" + x for x in cfgDict['INCLUDEPY'].split()])
++cmd.extend(["-I../../Include"])
++cmd.extend(extra_compile_args.split())
++cmd.extend(sources.split())
++cmd.extend(["-lpython%s" % cfgDict['VERSION']])
+
+-print 'cmd = ', cmd
+-os.system(cmd)
++print 'cmd =', " ".join(cmd)
++sys.exit(subprocess.call(cmd))
diff --git a/dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch b/dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch
new file mode 100644
index 000000000000..622032d4d174
--- /dev/null
+++ b/dev-python/scientificpython/files/scientificpython-2.9.1-mpi-netcdf.patch
@@ -0,0 +1,29 @@
+--- setup.py
++++ setup.py
+@@ -2,7 +2,7 @@
+
+ from distutils.core import setup, Extension
+ from distutils.command.install_headers import install_headers
+-import os, sys, platform
++import os, sys, platform, subprocess
+ from glob import glob
+
+ class Dummy:
+@@ -103,13 +103,16 @@
+ netcdf_include = os.path.join(netcdf_prefix, 'include')
+ netcdf_h_file = os.path.join(netcdf_prefix, 'include', 'netcdf.h')
+ netcdf_lib = os.path.join(netcdf_prefix, 'lib')
++ mpi_cflags = subprocess.Popen(["mpicc", "-showme:compile"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
++ mpi_ldflags = subprocess.Popen(["mpicc", "-showme:link"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
+ ext_modules = [Extension('Scientific_netcdf',
+ ['Src/Scientific_netcdf.c'],
+ include_dirs=['Include', netcdf_include]
+ + arrayobject_h_include,
+ library_dirs=[netcdf_lib],
+ libraries = ['netcdf'],
+- extra_compile_args=extra_compile_args)]
++ extra_compile_args=extra_compile_args + mpi_cflags,
++ extra_link_args=mpi_ldflags)]
+
+ try:
+ # Add code for including documentation in Mac packages
diff --git a/dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch b/dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch
new file mode 100644
index 000000000000..c9672948f2f8
--- /dev/null
+++ b/dev-python/scientificpython/files/scientificpython-2.9.3-mpi-netcdf.patch
@@ -0,0 +1,43 @@
+From 71a5e881290c1cec2506a346e2740a1b821c36aa Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 13 Mar 2014 15:29:33 +0100
+Subject: [PATCH] Include MPI cflags/ldflags for netcdf.
+
+---
+ setup.py | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 7f01656..71ac92a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -2,7 +2,7 @@
+
+ from distutils.core import setup, Extension
+ from distutils.command.install_headers import install_headers
+-import os, sys, platform
++import os, sys, platform, subprocess
+ from glob import glob
+
+ class Dummy:
+@@ -92,13 +92,16 @@ else:
+ netcdf_include = os.path.join(netcdf_prefix, 'include')
+ netcdf_h_file = os.path.join(netcdf_prefix, 'include', 'netcdf.h')
+ netcdf_lib = os.path.join(netcdf_prefix, 'lib')
++ mpi_cflags = subprocess.Popen(["mpicc", "-showme:compile"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
++ mpi_ldflags = subprocess.Popen(["mpicc", "-showme:link"], stdout=subprocess.PIPE).communicate()[0].rstrip().split()
+ ext_modules = [Extension('Scientific._netcdf',
+ ['Scientific/_netcdf.c'],
+ include_dirs=['Include', netcdf_include]
+ + numpy_include,
+ library_dirs=[netcdf_lib],
+ libraries = ['netcdf'],
+- extra_compile_args=extra_compile_args)]
++ extra_compile_args=extra_compile_args + mpi_cflags,
++ extra_link_args=mpi_ldflags)]
+
+ try:
+ # Add code for including documentation in Mac packages
+--
+1.9.0
+
diff --git a/dev-python/scientificpython/metadata.xml b/dev-python/scientificpython/metadata.xml
new file mode 100644
index 000000000000..60d277ea12fa
--- /dev/null
+++ b/dev-python/scientificpython/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>python</herd>
+ <longdescription lang="en">
+ ScientificPython is a collection of Python modules that are useful for
+ scientific computing. In this collection you will find modules that
+ cover basic geometry (vectors, tensors, transformations, vector and
+ tensor fields), quaternions, automatic derivatives, linear
+ interpolation, polynomials, elementary statistics, nonlinear
+ least-squares fits, unit calculations, Fortran-compatible text
+ formatting, 3D visualization via VRML, and two Tk widgets for simple
+ line plots and 3D wireframe models.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/scientificpython/scientificpython-2.9.1.ebuild b/dev-python/scientificpython/scientificpython-2.9.1.ebuild
new file mode 100644
index 000000000000..b8619890c09f
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils
+
+MY_PN="ScientificPython"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Scientific Module for Python"
+DOWNLOAD_NUMBER="3420"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+IUSE="doc mpi test"
+
+RDEPEND="
+ <dev-python/numpy-1.9
+ dev-python/pyro:3
+ sci-libs/netcdf
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+PYTHON_MODNAME="Scientific"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/${PN}-2.9-mpi.patch"
+ use mpi && epatch "${FILESDIR}/${P}-mpi-netcdf.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use mpi; then
+ cd Src/MPI
+ building_of_mpipython() {
+ PYTHONPATH="$(ls -d ../../build-${PYTHON_ABI}/lib*)" "$(PYTHON)" compile.py
+ mv -f mpipython mpipython-${PYTHON_ABI}
+ }
+ python_execute_function \
+ --action-message 'Building of mpipython with $(python_get_implementation) $(python_get_version)' \
+ --failure-message 'Building of mpipython failed with $(python_get_implementation) $(python_get_version)' \
+ building_of_mpipython
+ fi
+}
+
+src_test() {
+ cd Tests
+ python_execute_nosetests -P '$(ls -d ../build-${PYTHON_ABI}/lib.*)'
+}
+
+src_install() {
+ distutils_src_install
+ # do not install bsp related stuff, since we don't compile the interface
+ dodoc README README.MPI Doc/CHANGELOG || die "dodoc failed"
+ insinto /usr/share/doc/${PF}
+ doins Examples/{demomodule.c,netcdf_demo.py} || die "doins examples failed"
+
+ if use mpi; then
+ installation_of_mpipython() {
+ dobin Src/MPI/mpipython-${PYTHON_ABI}
+ }
+ python_execute_function -q installation_of_mpipython
+ python_generate_wrapper_scripts "${ED}usr/bin/mpipython"
+ doins Examples/mpi.py || die "doins mpi example failed failed"
+ fi
+
+ if use doc; then
+ dohtml Doc/Reference/* || die "dohtml failed"
+ fi
+}
diff --git a/dev-python/scientificpython/scientificpython-2.9.3.ebuild b/dev-python/scientificpython/scientificpython-2.9.3.ebuild
new file mode 100644
index 000000000000..805e26d45d4b
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="ScientificPython"
+MY_P="${MY_PN}-${PV}"
+DOWNLOAD_NUMBER=4425
+
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc mpi test"
+
+RDEPEND="
+ <dev-python/numpy-1.9[${PYTHON_USEDEP}]
+ dev-python/pyro:3[${PYTHON_USEDEP}]
+ sci-libs/netcdf
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.9-mpi.patch )
+DOCS=( README README.MPI Doc/CHANGELOG Examples/demomodule.c Examples/netcdf_demo.py )
+
+python_prepare_all() {
+ use mpi && PATCHES+=( "${FILESDIR}"/${PN}-2.9.3-mpi-netcdf.patch )
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use mpi; then
+ cd Src/MPI || die
+ ${PYTHON} compile.py || die
+ mv -f mpipython mpipython-${EPYTHON} || die
+ fi
+}
+
+python_test() {
+ cd "${S}"/Tests || die
+ python_foreach_impl nosetests
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if use mpi; then
+ cd Src/MPI || die
+ python_newexe mpipython-${EPYTHON} mpipython
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( Doc/Reference/. )
+ use mpi && EXAMPLES=( Examples/mpi.py )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/scientificpython/scientificpython-2.9.4.ebuild b/dev-python/scientificpython/scientificpython-2.9.4.ebuild
new file mode 100644
index 000000000000..93af0d21a04a
--- /dev/null
+++ b/dev-python/scientificpython/scientificpython-2.9.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="ScientificPython"
+MY_P="${MY_PN}-${PV}"
+DOWNLOAD_NUMBER=4570
+
+DESCRIPTION="Scientific Module for Python"
+SRC_URI="http://sourcesup.cru.fr/frs/download.php/${DOWNLOAD_NUMBER}/${MY_P}.tar.gz"
+HOMEPAGE="http://sourcesup.cru.fr/projects/scientific-py/"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc mpi test"
+
+RDEPEND="
+ <dev-python/numpy-1.9[${PYTHON_USEDEP}]
+ dev-python/pyro:3[${PYTHON_USEDEP}]
+ sci-libs/netcdf
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.9-mpi.patch )
+DOCS=( README README.MPI Doc/CHANGELOG Examples/demomodule.c Examples/netcdf_demo.py )
+
+python_prepare_all() {
+ use mpi && PATCHES+=( "${FILESDIR}"/${PN}-2.9.3-mpi-netcdf.patch )
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use mpi; then
+ cd Src/MPI || die
+ ${PYTHON} compile.py || die
+ mv -f mpipython mpipython-${EPYTHON} || die
+ fi
+}
+
+python_test() {
+ cd "${S}"/Tests || die
+ python_foreach_impl nosetests
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if use mpi; then
+ cd Src/MPI || die
+ python_newexe mpipython-${EPYTHON} mpipython
+ fi
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( Doc/Reference/. )
+ use mpi && EXAMPLES=( Examples/mpi.py )
+ distutils-r1_python_install_all
+}