summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-01 00:02:27 +0100
committerSam James <sam@gentoo.org>2022-08-01 00:02:27 +0100
commit121e6a1633b2dbde9d83485f7bb39a682ebac641 (patch)
tree4e9f751b7be6001f6415579ef68a81a46f885e5a /dev-python/scipy
parentmail-filter/libmilter: avoid grep -P (diff)
downloadgentoo-121e6a1633b2dbde9d83485f7bb39a682ebac641.tar.gz
gentoo-121e6a1633b2dbde9d83485f7bb39a682ebac641.tar.bz2
gentoo-121e6a1633b2dbde9d83485f7bb39a682ebac641.zip
dev-python/scipy: fix USE=doc
Closes: https://bugs.gentoo.org/862567 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.9.0-r1.ebuild8
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild10
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-python/scipy/scipy-1.9.0-r1.ebuild b/dev-python/scipy/scipy-1.9.0-r1.ebuild
index c6b76d728e36..47dd4358d2c0 100644
--- a/dev-python/scipy/scipy-1.9.0-r1.ebuild
+++ b/dev-python/scipy/scipy-1.9.0-r1.ebuild
@@ -81,6 +81,14 @@ EPYTEST_DESELECT=(
distutils_enable_tests pytest
+src_unpack() {
+ default
+
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
python_test() {
cd "${T}" || die
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index 888ff2073ebb..47dd4358d2c0 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -38,7 +38,7 @@ else
S="${WORKDIR}"/${MY_P}
if [[ ${PV} != *rc* ]] ; then
- KEYWORDS="~amd64 -hppa"
+ KEYWORDS="~amd64 -hppa ~ppc64 ~riscv"
fi
fi
@@ -81,6 +81,14 @@ EPYTEST_DESELECT=(
distutils_enable_tests pytest
+src_unpack() {
+ default
+
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
+ fi
+}
+
python_test() {
cd "${T}" || die