summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sclapp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sclapp')
-rw-r--r--dev-python/sclapp/Manifest1
-rw-r--r--dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch40
-rw-r--r--dev-python/sclapp/metadata.xml8
-rw-r--r--dev-python/sclapp/sclapp-0.5.3-r1.ebuild35
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/sclapp/Manifest b/dev-python/sclapp/Manifest
new file mode 100644
index 000000000000..aa7e7a823da7
--- /dev/null
+++ b/dev-python/sclapp/Manifest
@@ -0,0 +1 @@
+DIST sclapp-0.5.3.tar.gz 47646 SHA256 e8e8b60cea9b09acc08f237e92c8b86057bdfd735412aa88cc993fea29031768 SHA512 e615310b2ede517717cf8ef70aca02c070676d71fb8880e381e3cc66d5c6006e47b4dd7c4355dbcb34e76898ce7a7a2e4522454490353970ac185c5d1963e49f WHIRLPOOL 49b940319e4f87dbc973081ec2ec7ad3b445d79a56ab23bf1ba58950ca3010eb5b2fb8666fe26677214bc07cb5bb2a8d7faeec0878e55c27e3644a19cf46d49f
diff --git a/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch b/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch
new file mode 100644
index 000000000000..45965f01b1de
--- /dev/null
+++ b/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch
@@ -0,0 +1,40 @@
+=== modified file 'NEWS'
+--- NEWS 2009-01-14 11:11:28 +0000
++++ NEWS 2009-12-21 14:12:02 +0000
+@@ -25,6 +25,9 @@
+
+ (Forest Bond)
+
++ * Fixed output protection test that was failing on some systems.
++ (Forest Bond)
++
+
+ sclapp 0.5.3 2008-07-21
+ =======================
+
+=== modified file 'tests/output_protection.py'
+--- tests/output_protection.py 2008-05-18 21:46:03 +0000
++++ tests/output_protection.py 2009-12-21 14:12:02 +0000
+@@ -109,8 +109,10 @@
+ exceptions = ()):
+ def test_fn():
+ pid = failure_fn(main_fn)
+- assertLogFileContainsExactly('foo', foos)
+- assertLogFileContainsExactly('bar', bars)
++ if foos is not None:
++ assertLogFileContainsExactly('foo', foos)
++ if bars is not None:
++ assertLogFileContainsExactly('bar', bars)
+ for signal in signals:
+ assertSignalCaught(signal, pid)
+ for exception in exceptions:
+@@ -171,7 +173,7 @@
+ 'test_stdout_fails_without_signal_handling_without_output_protection',
+ _stdout_fails,
+ main_without_signal_handling_without_output_protection,
+- 2, 2, ()
++ 2, None, ()
+ )))
+ test_stdout_stderr_fail_without_signal_handling_without_output_protection = (
+ staticmethod(_make_test_fn(
+
diff --git a/dev-python/sclapp/metadata.xml b/dev-python/sclapp/metadata.xml
new file mode 100644
index 000000000000..16bcc9f800a2
--- /dev/null
+++ b/dev-python/sclapp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/sclapp/sclapp-0.5.3-r1.ebuild b/dev-python/sclapp/sclapp-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..41d8de2c9966
--- /dev/null
+++ b/dev-python/sclapp/sclapp-0.5.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Framework for writing simple command-line applications"
+HOMEPAGE="http://forestbond.com/media/docs/${P}.html"
+SRC_URI="http://www.alittletooquiet.net/media/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/pexpect[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-testsuite-fix-from-r235.patch"
+)
+
+src_test() {
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ esetup.py test
+}