summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-26 11:25:51 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-26 11:25:51 +0200
commitbc7d04a381c2f5b3195f0317e694c288ce72b986 (patch)
tree5bbfe41b080249db3a9ec47a067c6cc1134831c6 /dev-python/scrapy
parentdev-python/pandas: Remove support for non-existent deps (diff)
downloadgentoo-bc7d04a381c2f5b3195f0317e694c288ce72b986.tar.gz
gentoo-bc7d04a381c2f5b3195f0317e694c288ce72b986.tar.bz2
gentoo-bc7d04a381c2f5b3195f0317e694c288ce72b986.zip
dev-python/scrapy: Revert "version bump to 1.4.0."
The version bump had missing dependencies which were not fixed since it was merged. Bug: https://bugs.gentoo.org/626550
Diffstat (limited to 'dev-python/scrapy')
-rw-r--r--dev-python/scrapy/Manifest1
-rw-r--r--dev-python/scrapy/scrapy-1.4.0.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-python/scrapy/Manifest b/dev-python/scrapy/Manifest
index 9b05991ab894..bfb8e60f4f1d 100644
--- a/dev-python/scrapy/Manifest
+++ b/dev-python/scrapy/Manifest
@@ -1,2 +1 @@
DIST scrapy-1.0.3.tar.gz 1006911 BLAKE2B 19f53eb9580c383dd92852f3d270b7c031d3f67dae56dea73d3be346b5b39ed7d63ca345425c48466080e84d2ee82f08f9e46140d65c1b57fc22672897fc0b98 SHA512 bf61d449d7309de0ebdc36c73371d01518ee5cfa5d4ac1b68ee42389466ee15dba82690dbc885aa6bc1b9fe0b2e29a03fb3a3af3889842e1039e3a81749fc0c0
-DIST scrapy-1.4.0.tar.gz 1114816 BLAKE2B 4ab32584c46cc7cae02d231b536a6e5620202e28a57ecfc370aa627419c38e8a2036f3cf67e42f85a76baf8e5b098b8e9e953f0cf9d88fd889b3a510b9258c1d SHA512 1442cae1a26b5c7c8c27998ec6ef9ab374111221180a5933d53aff0c7aeb31102882c387581c1455c1dd246e11f0c0f5ab5989a21037204e5314054e303f7312
diff --git a/dev-python/scrapy/scrapy-1.4.0.ebuild b/dev-python/scrapy/scrapy-1.4.0.ebuild
deleted file mode 100644
index ba726b0ccdeb..000000000000
--- a/dev-python/scrapy/scrapy-1.4.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="A high-level Python Screen Scraping framework"
-HOMEPAGE="https://github.com/scrapy/scrapy/
- https://pypi.org/project/Scrapy/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="boto doc ibl test ssl"
-
-RDEPEND="
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- dev-libs/libxml2[python,${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- >=dev-python/parsel-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-3.4[${PYTHON_USEDEP}]
- ibl? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}] )
- boto? ( dev-python/boto3[${PYTHON_USEDEP}] )
- >=dev-python/twisted-14.0[${PYTHON_USEDEP}]
- >=dev-python/w3lib-1.8.0[${PYTHON_USEDEP}]
- dev-python/queuelib[${PYTHON_USEDEP}]
- >=dev-python/cssselect-0.9[${PYTHON_USEDEP}]
- >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
- dev-python/service_identity[${PYTHON_USEDEP}]
- "
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- =net-proxy/mitmproxy-0.10.1[${PYTHON_USEDEP}]
- =dev-python/netlib-0.10.1[${PYTHON_USEDEP}]
- dev-python/jmespath[${PYTHON_USEDEP}]
- dev-python/testfixtures[${PYTHON_USEDEP}]
- net-ftp/vsftpd
- )"
-# pytest-twisted listed as a test dep but not in portage.
-# Testsuite currently survives without it, so appears optional
-
-REQUIRED_USE="test? ( ssl boto )"
-
-python_prepare_all() {
- # https://github.com/scrapy/scrapy/issues/1464
- # Disable failing tests known to pass according to upstream
- # Awaiting a fix planned by package owner.
- sed -e 's:test_https_connect_tunnel:_&:' \
- -e 's:test_https_connect_tunnel_error:_&:' \
- -e 's:test_https_tunnel_auth_error:_&:' \
- -e 's:test_https_tunnel_without_leak_proxy_authorization_header:_&:' \
- -i tests/test_proxy_connect.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- PYTHONPATH="${S}" emake -C docs html || die "emake html failed"
- fi
-}
-
-python_test() {
- py.test ${PN} tests || die "tests failed"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}