summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-17 13:18:56 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-17 14:14:52 +0200
commit4829ba4c1a3905acbf5cf3a2bfb5c34fbbd85901 (patch)
treee1444f9a47e722a3986dfe9664c09aa7b0877f73 /dev-python/scripttest/scripttest-1.3.0.ebuild
parentdev-python/pysrt: Add python3_6 (diff)
downloadgentoo-4829ba4c1a3905acbf5cf3a2bfb5c34fbbd85901.tar.gz
gentoo-4829ba4c1a3905acbf5cf3a2bfb5c34fbbd85901.tar.bz2
gentoo-4829ba4c1a3905acbf5cf3a2bfb5c34fbbd85901.zip
dev-python/scripttest: Use GitHub tarball to run tests
Diffstat (limited to 'dev-python/scripttest/scripttest-1.3.0.ebuild')
-rw-r--r--dev-python/scripttest/scripttest-1.3.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/scripttest/scripttest-1.3.0.ebuild b/dev-python/scripttest/scripttest-1.3.0.ebuild
new file mode 100644
index 000000000000..0a1a9817255a
--- /dev/null
+++ b/dev-python/scripttest/scripttest-1.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A very small text templating language"
+HOMEPAGE="http://pythonpaste.org/scripttest/ https://pypi.python.org/pypi/ScriptTest"
+# pypi tarball lacks tests
+SRC_URI="https://github.com/pypa/scripttest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ esetup.py test
+}