summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 13:59:24 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 16:11:41 +0100
commit3f0d79b8bbe71a84b1d08620911625216baffbb5 (patch)
treeef88a775ee1dc22af73a231dd633f27fafd0f4c0 /dev-python/seaborn
parentdev-python/pytest-catchlog: Version Bump (diff)
downloadgentoo-3f0d79b8bbe71a84b1d08620911625216baffbb5.tar.gz
gentoo-3f0d79b8bbe71a84b1d08620911625216baffbb5.tar.bz2
gentoo-3f0d79b8bbe71a84b1d08620911625216baffbb5.zip
dev-python/seaborn: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/seaborn-0.7.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 24006cdc7114..1b35895c900a 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1,2 +1,3 @@
DIST seaborn-0.5.1.tar.gz 104426 SHA256 8c8f7f1036cf6155be3d987ee23d2eeeed8c272b0803b32b7d524614f8526688 SHA512 bbcdf0625e096b8f41d56521f3e319a64d82632131d80ed1e81144362fe881d9b5df4d3b5a5fa09363b1782897d9ac68d3fc647d82da4e0017c5dba21c897b8d WHIRLPOOL 682a32f2d40a742e87659f27a675c437875a4b4dfcfd8195b774c49ae38f5ad73ee4b73aa00dabab33ccb6015e5eb5326605c897c8b1cac341cc9db0d6143f73
DIST seaborn-0.6.0.tar.gz 145188 SHA256 e078399b56ed0d53a4aa8bd4d6bd4a9a9deebc0b4acad259d0ef81830affdb68 SHA512 3b7e7c1b72bd55aba012f312b43920044ea011648b4d855f4acd813ae644a75b4c60aa56c35ea759dcd7683bb6d9ea3b4f1209215950a5014ad46ebe04088fb1 WHIRLPOOL 66c9834f982f4a27c1a884bd4c8f73bb718fe0948bc7b3bde86f7d9bd354bbf783e36c576b8e2b0ded50cdf63244f463b9419e808ab70f6d5c2a24e89c570e99
+DIST seaborn-0.7.0.tar.gz 154263 SHA256 15a8b2747becfdb86cfa60b5fcfa9bb934e42ef0ced660e0d57e8aea741f7145 SHA512 475785b074c154e3f2442450c15926dddbbad6a76a808247aeab42eb5f6a0b92b7e2daf032f4adea62d7c9ef3ac3d6eb1bb9aaf35b152ca75faeaedb748e38be WHIRLPOOL bb15397b33487d3ece614ee35a7c7239d3ad616ea4c074f57672637f9193539a7bd923cb23a8c51cc5543bdb80e0e70a8e0bb4c30c69601b58a4f0ed1fc43809
diff --git a/dev-python/seaborn/seaborn-0.7.0.ebuild b/dev-python/seaborn/seaborn-0.7.0.ebuild
new file mode 100644
index 000000000000..dc414e346455
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/ https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+# https://github.com/mwaskom/seaborn/issues/836
+RESTRICT=test
+
+python_test() {
+ virtx nosetests --verbosity=3
+}