summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-24 01:18:02 +0000
committerSam James <sam@gentoo.org>2021-10-24 01:18:17 +0000
commit039b6d188d5d1277d78a069f744cbef95154a768 (patch)
tree3fb2d85ca964e7080b010d5a74153b42831f5ecb /dev-python/sentry-sdk
parentdev-python/rdflib: Stabilize 6.0.2 amd64, #819855 (diff)
downloadgentoo-039b6d188d5d1277d78a069f744cbef95154a768.tar.gz
gentoo-039b6d188d5d1277d78a069f744cbef95154a768.tar.bz2
gentoo-039b6d188d5d1277d78a069f744cbef95154a768.zip
dev-python/sentry-sdk: use EPYTEST_IGNORE to skip whole test files too
Bug: https://bugs.gentoo.org/819864 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild
index d0881dad90d7..c3d2764d4363 100644
--- a/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild
+++ b/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild
@@ -42,13 +42,16 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
- local deselect=(
+ local EPYTEST_IGNORE=(
# tests require Internet access
tests/integrations/httpx/test_httpx.py
tests/integrations/requests/test_requests.py
tests/integrations/stdlib/test_httplib.py
# wtf is it supposed to do?!
tests/integrations/gcp/test_gcp.py
+ )
+
+ local EPYTEST_DESELECT=(
# hangs
'tests/test_transport.py::test_transport_works[eventlet'
# TODO
@@ -68,5 +71,5 @@ python_test() {
# Needs to detect sentry-sdk in the installed modules
distutils_install_for_testing
- epytest ${deselect[@]/#/--deselect }
+ epytest
}