summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-29 23:25:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-29 23:59:35 +0200
commitc5e3af966552ab2c718d1fd0d3fbbb4f9d033708 (patch)
treeb7a3a3017a07f7420122979f0c5d9bf31ae7b323 /dev-python/sentry-sdk
parentdev-python/zipp: Bump to 3.6.0 (diff)
downloadgentoo-c5e3af966552ab2c718d1fd0d3fbbb4f9d033708.tar.gz
gentoo-c5e3af966552ab2c718d1fd0d3fbbb4f9d033708.tar.bz2
gentoo-c5e3af966552ab2c718d1fd0d3fbbb4f9d033708.zip
dev-python/sentry-sdk: Bump to 1.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index 4fe2570e0cb0..d682a4ec72d2 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -2,3 +2,4 @@ DIST sentry-sdk-1.3.1.tar.gz 219705 BLAKE2B 3fc8f81a5f762f400c70ae1c83ab46e97ec4
DIST sentry-sdk-1.4.0.tar.gz 230870 BLAKE2B 8cad1f0046219b60af982d3a01ae67aa1b018c4c8815c2adae834beeea6015057791abff6e1213a4a5902fe62e56f232dcb0cb355927c2f986751145dc633962 SHA512 b1f3021b4a67c2c4e13109ec3e189d1e133f07ecad18bc3e0ebd7b99e90b53aa83cac2cc567b8b47763892a9e06e1795aca497f146cbaae15952c880f9c160cd
DIST sentry-sdk-1.4.1.tar.gz 230985 BLAKE2B 0c193d5d564377d484e8e1ba2d30580ad373114e6a1eb3c4d38af6d9745aa788d1369836c4686b80503a027810273cd3a2d1833a6df18d32e1f352f6fb418c8c SHA512 b38ce6448553a05158690808ed4e7013c44f35922c1eb1662f3f9fa73e1c5f9d8a5385eccb8ebd062eae27b7e037ce0c204778ffd24b9ccf38b14d8e511d4cc9
DIST sentry-sdk-1.4.2.tar.gz 231026 BLAKE2B 760d84b15ef6d002a3dbd92ce99efcd16738d4db9a2b47775d0da19649b85a0f3cd234a8ce98111599b27ad5c1e7eb901ff745d57c558f5603d4ea59b3ff5795 SHA512 227d5edb6e6585749df5e873e2c7c6191f96ea6071a22b44fb4901d5466218ca718ac81ec23a7c176c52734fad1f43331e58d670ee62c1892bf7768dd71f9fab
+DIST sentry-sdk-1.4.3.tar.gz 231054 BLAKE2B 39509b3f7b12e773e23881772cf2d3445374181f7bd23b3a7abe3cbdae012b03b43bcd4ce811a40cd2c7916cae378698ea5a53909b2f679d8b3f3598e675719e SHA512 bd5a1b75a437d28348f980cad0bad30cbcd2872fc9678e50d69bca73e0a08a8e663f0fd54607174122072dafad6055acc73db34c6ca92ec9d00efed41e5c1c97
diff --git a/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild b/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild
new file mode 100644
index 000000000000..d0881dad90d7
--- /dev/null
+++ b/dev-python/sentry-sdk/sentry-sdk-1.4.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Sentry"
+HOMEPAGE="https://sentry.io/ https://pypi.org/project/sentry-sdk/"
+SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/sentry-python-${PV}"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/executing[${PYTHON_USEDEP}]
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ dev-python/fakeredis[${PYTHON_USEDEP}]
+ dev-python/flask-login[${PYTHON_USEDEP}]
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pyrsistent[${PYTHON_USEDEP}]
+ dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # tests require Internet access
+ tests/integrations/httpx/test_httpx.py
+ tests/integrations/requests/test_requests.py
+ tests/integrations/stdlib/test_httplib.py
+ # wtf is it supposed to do?!
+ tests/integrations/gcp/test_gcp.py
+ # hangs
+ 'tests/test_transport.py::test_transport_works[eventlet'
+ # TODO
+ 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
+ tests/test_client.py::test_databag_depth_stripping
+ tests/test_client.py::test_databag_string_stripping
+ tests/test_client.py::test_databag_breadth_stripping
+ # incompatible version?
+ tests/integrations/falcon/test_falcon.py
+ # test_circular_references: apparently fragile
+ 'tests/integrations/threading/test_threading.py::test_circular_references'
+ # test for new feature, fails with IndexError
+ tests/integrations/wsgi/test_wsgi.py::test_session_mode_defaults_to_request_mode_in_wsgi_handler
+ )
+
+ # Prevent tests/integrations/modules/test_modules.py:test_basic failure
+ # Needs to detect sentry-sdk in the installed modules
+ distutils_install_for_testing
+
+ epytest ${deselect[@]/#/--deselect }
+}