summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-19 10:43:10 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-19 10:45:23 +0100
commit56a751463aeb77ca28cb18012f9dc350e36cf8eb (patch)
tree895a597ce7b6d2d9a85fed7c8951181fea674a91 /dev-python/service_identity
parentdev-python/attrs: Keyword under ALLARCHES policy (diff)
downloadgentoo-56a751463aeb77ca28cb18012f9dc350e36cf8eb.tar.gz
gentoo-56a751463aeb77ca28cb18012f9dc350e36cf8eb.tar.bz2
gentoo-56a751463aeb77ca28cb18012f9dc350e36cf8eb.zip
dev-python/service_identity: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/service_identity')
-rw-r--r--dev-python/service_identity/Manifest1
-rw-r--r--dev-python/service_identity/service_identity-16.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/service_identity/Manifest b/dev-python/service_identity/Manifest
index 4d5625d2214b..52e163594508 100644
--- a/dev-python/service_identity/Manifest
+++ b/dev-python/service_identity/Manifest
@@ -1 +1,2 @@
DIST service_identity-14.0.0.tar.gz 26033 SHA256 3105a319a7c558490666694f599be0c377ad54824eefb404cde4ce49e74a4f5a SHA512 d504ad388defb38a86ca82c8ff9582dbb664a929e4b4ee7f6732b2da5326c33b1764384a8d849972f83ae7800c775daf90c1f3fbc61b8d2c29294f44c7cd36d2 WHIRLPOOL bc6f3cba3e3bec83c527df60dc3cd4387d74baab5a88b5c2cb731661804139c78c86074902060b64e402364ac641b4b2617c98448d4a9e6b367dc0f9d6cd5dac
+DIST service_identity-16.0.0.tar.gz 30270 SHA256 0630e222f59f91f3db498be46b1d879ff220955d7bbad719a5cb9ad14e3c3036 SHA512 0ffa28b3dece2415a058ec159e4f85f3e86c0de520ed5d6933ec49edca91ccc79a57893ace40d5441455791433828ab55a939e90335dfdee8582627e33a896ae WHIRLPOOL 598c046bf0e7428d5d3c34e8315bc67a857377af105bddc7d07fde01eaaffb4be62026fdffab6c81eaaff897290ab735c5f3ad3f7f9c4a1bd9f932a39cef9aaf
diff --git a/dev-python/service_identity/service_identity-16.0.0.ebuild b/dev-python/service_identity/service_identity-16.0.0.ebuild
new file mode 100644
index 000000000000..4486647524b0
--- /dev/null
+++ b/dev-python/service_identity/service_identity-16.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Service identity verification for pyOpenSSL"
+HOMEPAGE="https://github.com/pyca/service_identity"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test -v -v -x || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}