summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/service_identity
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/service_identity')
-rw-r--r--dev-python/service_identity/Manifest1
-rw-r--r--dev-python/service_identity/metadata.xml9
-rw-r--r--dev-python/service_identity/service_identity-14.0.0.ebuild47
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/service_identity/Manifest b/dev-python/service_identity/Manifest
new file mode 100644
index 000000000000..4d5625d2214b
--- /dev/null
+++ b/dev-python/service_identity/Manifest
@@ -0,0 +1 @@
+DIST service_identity-14.0.0.tar.gz 26033 SHA256 3105a319a7c558490666694f599be0c377ad54824eefb404cde4ce49e74a4f5a SHA512 d504ad388defb38a86ca82c8ff9582dbb664a929e4b4ee7f6732b2da5326c33b1764384a8d849972f83ae7800c775daf90c1f3fbc61b8d2c29294f44c7cd36d2 WHIRLPOOL bc6f3cba3e3bec83c527df60dc3cd4387d74baab5a88b5c2cb731661804139c78c86074902060b64e402364ac641b4b2617c98448d4a9e6b367dc0f9d6cd5dac
diff --git a/dev-python/service_identity/metadata.xml b/dev-python/service_identity/metadata.xml
new file mode 100644
index 000000000000..9b8cc20e2223
--- /dev/null
+++ b/dev-python/service_identity/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">service_identity</remote-id>
+ <remote-id type="github">pyca/service_identity</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/service_identity/service_identity-14.0.0.ebuild b/dev-python/service_identity/service_identity-14.0.0.ebuild
new file mode 100644
index 000000000000..8857b7b8a506
--- /dev/null
+++ b/dev-python/service_identity/service_identity-14.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Service identity verification for pyOpenSSL"
+HOMEPAGE="https://github.com/pyca/service_identity"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE=" MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.12[${PYTHON_USEDEP}]
+ >=dev-python/characteristic-14.0.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # testsuite not supported by py3.2 which is about to become deprecated
+ if ! [[ "${EPYTHON}" == python3.2 ]]; then
+ py.test --cov service_identity --cov-report term-missing || die "tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}