summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-30 18:32:52 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-30 18:39:10 -0400
commit60d5ed642acd07aded96ef1ca445ac5b14cb02b0 (patch)
tree7767b4dfba94d6facf16946a46023f80604a82aa /dev-python/setuptools/setuptools-28.7.1.ebuild
parentapp-text/blogc: version bump (diff)
downloadgentoo-60d5ed642acd07aded96ef1ca445ac5b14cb02b0.tar.gz
gentoo-60d5ed642acd07aded96ef1ca445ac5b14cb02b0.tar.bz2
gentoo-60d5ed642acd07aded96ef1ca445ac5b14cb02b0.zip
dev-python/setuptools: version bump to 28.7.1
Diffstat (limited to 'dev-python/setuptools/setuptools-28.7.1.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-28.7.1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/setuptools/setuptools-28.7.1.ebuild b/dev-python/setuptools/setuptools-28.7.1.ebuild
new file mode 100644
index 000000000000..2adb9c7d49dc
--- /dev/null
+++ b/dev-python/setuptools/setuptools-28.7.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.python.org/pypi/setuptools"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+# >=dev-python/packaging-16.4[${PYTHON_USEDEP}]
+# >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+# "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+# >=dev-python/pyparsing-2.0.6[${PYTHON_USEDEP}]
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
+
+python_prepare_all() {
+ if [[ ${PV} == "9999" ]]; then
+ python_setup
+ ${EPYTHON} bootstrap.py || die
+ fi
+
+ # rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}