summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-12-12 15:33:27 +0100
committerMichał Górny <mgorny@gentoo.org>2018-12-12 17:06:31 +0100
commit9fc6f3fdc37c61b587b9e72358dbfac8ebaff43d (patch)
tree17988eb251b682fa95d79b1e9044b923da9c41eb /dev-python/setuptools/setuptools-34.0.2-r1.ebuild
parentdev-python/setuptools: Bump to 40.6.3 (diff)
downloadgentoo-9fc6f3fdc37c61b587b9e72358dbfac8ebaff43d.tar.gz
gentoo-9fc6f3fdc37c61b587b9e72358dbfac8ebaff43d.tar.bz2
gentoo-9fc6f3fdc37c61b587b9e72358dbfac8ebaff43d.zip
dev-python/setuptools: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/setuptools/setuptools-34.0.2-r1.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-34.0.2-r1.ebuild70
1 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/setuptools/setuptools-34.0.2-r1.ebuild b/dev-python/setuptools/setuptools-34.0.2-r1.ebuild
deleted file mode 100644
index 8e8af7fd82f7..000000000000
--- a/dev-python/setuptools/setuptools-34.0.2-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="Collection of extensions to Distutils"
-HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/packaging-16.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/appdirs-1.4.0-r1[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- app-arch/unzip
- test? (
- dev-python/pip[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-PDEPEND="
- >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"
-
-# Force in-source build because build system modifies sources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
-
-python_prepare_all() {
- if [[ ${PV} == "9999" ]]; then
- python_setup
- ${EPYTHON} bootstrap.py || die
- fi
-
- # disable tests requiring a network connection
- rm setuptools/tests/test_packageindex.py || die
-
- # don't run integration tests
- rm setuptools/tests/test_integration.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
- # It tries to sandbox the test in a tempdir
- HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
- distutils-r1_python_install
-}