summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-25 12:59:33 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-25 16:11:41 +0100
commitd038638f1e09d93257a3bd8926124dda008beeec (patch)
tree6ea4dc9ff07ddd240db314f4e17c3293713142b3 /dev-python/setuptools/setuptools-9999.ebuild
parentdev-python/sphinx: Version Bump (diff)
downloadgentoo-d038638f1e09d93257a3bd8926124dda008beeec.tar.gz
gentoo-d038638f1e09d93257a3bd8926124dda008beeec.tar.bz2
gentoo-d038638f1e09d93257a3bd8926124dda008beeec.zip
dev-python/setuptools: Version Bump
Propargate changes to live ebuild Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/setuptools/setuptools-9999.ebuild')
-rw-r--r--dev-python/setuptools/setuptools-9999.ebuild48
1 files changed, 28 insertions, 20 deletions
diff --git a/dev-python/setuptools/setuptools-9999.ebuild b/dev-python/setuptools/setuptools-9999.ebuild
index 33649763d2f3..972ed4c32177 100644
--- a/dev-python/setuptools/setuptools-9999.ebuild
+++ b/dev-python/setuptools/setuptools-9999.ebuild
@@ -1,30 +1,34 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+EAPI=6
-inherit distutils-r1
-#if LIVE
-inherit mercurial
-#endif
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-DESCRIPTION="a collection of extensions to Distutils"
+inherit distutils-r1 mercurial
+
+DESCRIPTION="Collection of extensions to Distutils"
HOMEPAGE="https://pypi.python.org/pypi/setuptools"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI=""
+EHG_REPO_URI="https://bitbucket.org/pypa/setuptools"
-LICENSE="PSF-2"
+LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-#if LIVE
-SRC_URI=""
KEYWORDS=""
-EHG_REPO_URI="https://bitbucket.org/pypa/setuptools"
-#endif
+IUSE="test"
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/packaging-15.3-r1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND=">=dev-python/certifi-2015.11.20[${PYTHON_USEDEP}]"
# Force in-source build because build system modifies sources.
DISTUTILS_IN_SOURCE_BUILD=1
@@ -32,8 +36,12 @@ DISTUTILS_IN_SOURCE_BUILD=1
DOCS=( README.txt docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )
python_prepare_all() {
- # Disable tests requiring network connection.
- rm -f setuptools/tests/test_packageindex.py
+ rm -r ./pkg_resources/_vendor || die
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
distutils-r1_python_prepare_all
}
@@ -41,7 +49,7 @@ python_prepare_all() {
python_test() {
# test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
# It tries to sandbox the test in a tempdir
- HOME="${PWD}" esetup.py test
+ HOME="${PWD}" py.test --verbose ${PN} || die "Tests failed under ${EPYTHON}"
}
python_install() {