summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-03-11 21:08:28 +0100
committerPacho Ramos <pacho@gentoo.org>2020-03-11 22:28:52 +0100
commit2b63e7b3f8183a3d97f927d5de481aa41511a689 (patch)
treeb548bced8a5bb491be0ce406a7fc643511ad4ebc /dev-python/setuptools_scm_git_archive
parentdev-python/booleanOperations: Bump to 0.9.0 (diff)
downloadgentoo-2b63e7b3f8183a3d97f927d5de481aa41511a689.tar.gz
gentoo-2b63e7b3f8183a3d97f927d5de481aa41511a689.tar.bz2
gentoo-2b63e7b3f8183a3d97f927d5de481aa41511a689.zip
dev-python/setuptools_scm_git_archive: Bump to 1.1
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/setuptools_scm_git_archive')
-rw-r--r--dev-python/setuptools_scm_git_archive/Manifest1
-rw-r--r--dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm_git_archive/Manifest b/dev-python/setuptools_scm_git_archive/Manifest
index 142571b1489b..baa0a1c8098d 100644
--- a/dev-python/setuptools_scm_git_archive/Manifest
+++ b/dev-python/setuptools_scm_git_archive/Manifest
@@ -1 +1,2 @@
DIST setuptools_scm_git_archive-1.0.tar.gz 2553 BLAKE2B a5ed592384800585b3f58b40571edc929872908bcb5e2d012cefe34e6cd84ee420a3bbbb9e856ef0fbbb972931abb4913d245b98d54b82aaf659247b92a1303e SHA512 fd1a06c86d1a8394e37b91d374b93dd5902906795360688b49077a4530240fd6be575ee66d51c3f61931bc837711bc3c59491d7c9cd165c34e2ec1f314b4cfbc
+DIST setuptools_scm_git_archive-1.1.tar.gz 2584 BLAKE2B 7c7569a92300be966b5447b1ab6c30a982c837efdb7a125173f6014420d78cf28e0d8cb0f04c4349ce364219e1567bcbc2e13bd85cb7627d3bdbae9c7974385b SHA512 73783d60d33782fb18012e64685db6333a2dda1be41ce75e0cd74a81585d8ebb7c85f23371056a42974c93b2d4a0633338945cf2a2219b0ee2a21f063dad8809
diff --git a/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
new file mode 100644
index 000000000000..0747a0892490
--- /dev/null
+++ b/dev-python/setuptools_scm_git_archive/setuptools_scm_git_archive-1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A setuptools_scm plugin for git archives"
+HOMEPAGE="https://github.com/Changaco/setuptools_scm_git_archive"
+SRC_URI="https://github.com/Changaco/setuptools_scm_git_archive/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV}"
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test
+}