summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-17 21:07:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-17 21:07:45 +0300
commit1450271cdd4fd7d5586c3eea9f13fd288ec6ae9d (patch)
tree936744669deca6674ac9436aa5b587ded033d253 /dev-python/sgmllib3k
parentapp-admin/entr: clean up old. (diff)
downloadgentoo-1450271cdd4fd7d5586c3eea9f13fd288ec6ae9d.tar.gz
gentoo-1450271cdd4fd7d5586c3eea9f13fd288ec6ae9d.tar.bz2
gentoo-1450271cdd4fd7d5586c3eea9f13fd288ec6ae9d.zip
dev-python/sgmllib3k: enable py3.10, add tests
Upstream repository is long gone, and with it the test file that could be used for testing. After long searches, found the test file in some web archive. But it needed small fixes for py3.10, which were done, and the test file was uploaded to ~arthurzam. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/sgmllib3k')
-rw-r--r--dev-python/sgmllib3k/Manifest1
-rw-r--r--dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild11
2 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/sgmllib3k/Manifest b/dev-python/sgmllib3k/Manifest
index 5f5d490e190d..2ace818dd118 100644
--- a/dev-python/sgmllib3k/Manifest
+++ b/dev-python/sgmllib3k/Manifest
@@ -1 +1,2 @@
DIST sgmllib3k-1.0.0.tar.gz 5750 BLAKE2B 188ac3c55245ff431e1ad7981f706f1a8fce3e9f3aaf844252c02da1189e5b9c7d29b76d803cbbcfc157fbb1ec7f36245186693472b95ed1634a2989185308ae SHA512 f9238afb831356f66b1c3e55975e0ea88007ffe1469b8b4e325e704d1915eb0ab120f5f9e98f36eeb4bf6204a1938d8a4d5a424f0cc054b141ac94adc8ef8ca9
+DIST test_sgmllib.py.gz 3769 BLAKE2B 026a843eaeb698d87e0137453b7f82763dee9a1ca446fc2c2fa9af8324297176749b041dfc2fc4c1954d743d9cfb7e773a189d99f22f7dc55ea1de486da80dd4 SHA512 722b79aa8b38626540bc331f9edb36919a8fb2561c5526be19509a58901aa1e2582e312fc2ace09cae54cb62577f266fcb10a1d98ab10685e2c79a17fea2f124
diff --git a/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild b/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild
index 7d34b5788ff5..d61a1417da37 100644
--- a/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild
+++ b/dev-python/sgmllib3k/sgmllib3k-1.0.0.ebuild
@@ -3,13 +3,20 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Py3k port of sgmllib"
HOMEPAGE="https://pypi.org/project/sgmllib3k/"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? ( https://dev.gentoo.org/~arthurzam/distfiles/dev-python/${PN}/test_sgmllib.py.gz )"
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+python_test() {
+ "${EPYTHON}" "${WORKDIR}/test_sgmllib.py" -v || die "Tests failed with ${EPYTHON}"
+}