summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-03-14 16:09:44 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-03-14 16:09:44 +0700
commitffc9820b1ae3de3aa928989a13b10ba86ba58065 (patch)
tree16f4d6439a099d28007df27a727d6eafe00d7e26 /dev-python/sh
parentdev-ruby/ruby-webkit2-gtk: cleanup (diff)
downloadgentoo-ffc9820b1ae3de3aa928989a13b10ba86ba58065.tar.gz
gentoo-ffc9820b1ae3de3aa928989a13b10ba86ba58065.tar.bz2
gentoo-ffc9820b1ae3de3aa928989a13b10ba86ba58065.zip
dev-python/sh: bump to 1.14.1
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/sh-1.14.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 7a8fd5dce64d..3febc4b9ae51 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-1.14.0.tar.gz 63313 BLAKE2B 9975944455077729d172a34dcf7847930f9bb943d5345729a9c09afeb411de72b59cd5e4f1192406ba8430a26439acd2ee4d477b10f31b5e55be936c711f70a9 SHA512 816c0562f4f779ba79b5206d151893cd5043898d1b74ee109c0ea67f862a097ab9c7509e4a20459fc623f14fa3fb1a9e2a2ccec8257a68fcba14414779a20128
+DIST sh-1.14.1.tar.gz 63317 BLAKE2B e4439a54d4bf2c106ae5217b55d6fa19f2bc369fb63e8515954a017fd2e98eca88fce07ea3efa70b3c427826bec657aa75c057a09c88de76c1595ef89465ee32 SHA512 9a4d9b841e81ae465b036f3fbf5e8ca277b090ffada660b17e9c2c457e09f7dbb0038b687fc0c0f4a6d575a55deb451c572a60f92f8c8d18ea65d6d902abb9b4
diff --git a/dev-python/sh/sh-1.14.1.ebuild b/dev-python/sh/sh-1.14.1.ebuild
new file mode 100644
index 000000000000..27df45dc064e
--- /dev/null
+++ b/dev-python/sh/sh-1.14.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="https://github.com/amoffat/sh"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}/sh-1.12.14-skip-unreliable-test.patch"
+ "${FILESDIR}/sh-1.14.0-skip-unreliable-test.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}