summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:47:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:30 +0100
commitcc09b5bb8aa4d714dd6f925d4fa858c328cffc82 (patch)
tree28078d1b55b7fe797a617a461ddb6fb32029717f /dev-python/signature_dispatch
parentdev-python/sexpdata: Switch to PEP 517 build (diff)
downloadgentoo-cc09b5bb8aa4d714dd6f925d4fa858c328cffc82.tar.gz
gentoo-cc09b5bb8aa4d714dd6f925d4fa858c328cffc82.tar.bz2
gentoo-cc09b5bb8aa4d714dd6f925d4fa858c328cffc82.zip
dev-python/signature_dispatch: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/signature_dispatch')
-rw-r--r--dev-python/signature_dispatch/signature_dispatch-1.0.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/signature_dispatch/signature_dispatch-1.0.0-r1.ebuild b/dev-python/signature_dispatch/signature_dispatch-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..04c1d7b39678
--- /dev/null
+++ b/dev-python/signature_dispatch/signature_dispatch-1.0.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Execute the first function that matches the given arguments"
+HOMEPAGE="
+ https://github.com/kalekundert/signature_dispatch/
+ https://pypi.org/project/signature-dispatch/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+RDEPEND="
+ dev-python/typeguard[${PYTHON_USEDEP}]"