summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-29 17:03:47 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-29 17:41:47 +0100
commitd5f5cbd2f9f75252d653db361cf06cb7bd908dad (patch)
tree5414d9684d36fe90ebaeddb63e84557d553386d6 /dev-python/simplebayes/simplebayes-1.5.8.ebuild
parentnet-print/cndrvcups-common-lb: Respect AR, prune static-libs (diff)
downloadgentoo-d5f5cbd2f9f75252d653db361cf06cb7bd908dad.tar.gz
gentoo-d5f5cbd2f9f75252d653db361cf06cb7bd908dad.tar.bz2
gentoo-d5f5cbd2f9f75252d653db361cf06cb7bd908dad.zip
dev-python/simplebayes: ebuild 1.5.8 bump
This uses pypi tarball, github 1.5.7 is equivalent Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-python/simplebayes/simplebayes-1.5.8.ebuild')
-rw-r--r--dev-python/simplebayes/simplebayes-1.5.8.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/simplebayes/simplebayes-1.5.8.ebuild b/dev-python/simplebayes/simplebayes-1.5.8.ebuild
new file mode 100644
index 000000000000..efe01695e0b0
--- /dev/null
+++ b/dev-python/simplebayes/simplebayes-1.5.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="memory-based, optional-persistence naive bayesian text classifier"
+HOMEPAGE="https://github.com/hickeroar/simplebayes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}