summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2015-10-10 17:13:48 +0200
committerCédric Krier <cedk@gentoo.org>2015-10-10 17:30:15 +0200
commitb3251116b83544f3554a469360c6682a12e20fd3 (patch)
treeaa19142db74ae19cacb2eb6f426d293d4cb3ac17 /dev-python/simpleeval/simpleeval-0.8.6.ebuild
parentsys-libs/libselinux: Add python3.5 compat (diff)
downloadgentoo-b3251116b83544f3554a469360c6682a12e20fd3.tar.gz
gentoo-b3251116b83544f3554a469360c6682a12e20fd3.tar.bz2
gentoo-b3251116b83544f3554a469360c6682a12e20fd3.zip
dev-python/simpleeval: version bump to 0.8.6
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/simpleeval/simpleeval-0.8.6.ebuild')
-rw-r--r--dev-python/simpleeval/simpleeval-0.8.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/simpleeval/simpleeval-0.8.6.ebuild b/dev-python/simpleeval/simpleeval-0.8.6.ebuild
new file mode 100644
index 000000000000..daeac387cd27
--- /dev/null
+++ b/dev-python/simpleeval/simpleeval-0.8.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, safe single expression evaluator library"
+HOMEPAGE="https://github.com/danthedeckie/simpleeval"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS="README.rst"
+
+python_test() {
+ esetup.py test
+}