summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-25 07:57:50 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-25 07:59:23 -0500
commit9d74d38e49bb438dfff36fab754b0a1820c82e17 (patch)
treee2db1a2038d3b082820787f58dbf70d7b1f4b045 /dev-python/simplejson/simplejson-3.13.2.ebuild
parentx11-wm/lumina: cleaning 1.4.0-r1 (diff)
downloadgentoo-9d74d38e49bb438dfff36fab754b0a1820c82e17.tar.gz
gentoo-9d74d38e49bb438dfff36fab754b0a1820c82e17.tar.bz2
gentoo-9d74d38e49bb438dfff36fab754b0a1820c82e17.zip
dev-python/simplejson: version bump to 3.13.2
Diffstat (limited to 'dev-python/simplejson/simplejson-3.13.2.ebuild')
-rw-r--r--dev-python/simplejson/simplejson-3.13.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.13.2.ebuild b/dev-python/simplejson/simplejson-3.13.2.ebuild
new file mode 100644
index 000000000000..63006c9caf2e
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.13.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}