summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-10-24 14:02:23 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-10-24 14:02:23 +0200
commitf3b69213a234e2125a1203eb3cdfd9ff4326949a (patch)
treef212d070c28b648eeea69eef1de2cfc73f8976d6 /dev-python/simplejson
parentdev-python/pytz: Removed old. (diff)
downloadgentoo-f3b69213a234e2125a1203eb3cdfd9ff4326949a.tar.gz
gentoo-f3b69213a234e2125a1203eb3cdfd9ff4326949a.tar.bz2
gentoo-f3b69213a234e2125a1203eb3cdfd9ff4326949a.zip
dev-python/simplejson: Bump to version 3.9.0
Package-Manager: portage-2.3.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.9.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 42e26270cd35..fafa7a91254f 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1,2 +1,3 @@
DIST simplejson-3.8.1.tar.gz 76033 SHA256 428ac8f3219c78fb04ce05895d5dff9bd813c05a9a7922c53dc879cd32a12493 SHA512 9c135347a015f5fbb4373da61282230430320c89bc1114f7487eb632bccbe29a4b2c396d724c6c72af5c7df78f1676869a037be9d137b4f29f18e82a9eb2b1f5 WHIRLPOOL 8441ccaff4e4115d58461f528179c4fc25139b5f7f86cc85826798e392e664154468f1fa2471f18fc7bd518adf06a75b493218765ca4df022d92e6ee24552e38
DIST simplejson-3.8.2.tar.gz 76578 SHA256 d58439c548433adcda98e695be53e526ba940a4b9c44fb9a05d92cd495cdd47f SHA512 041445bcee97e37361ed6270937fb4e74b6fc05988678da213ddc4f57f83134bfc933b0fb22101c387898bffac1b29d6eb78f03ec0853cf1086b155cee6ca309 WHIRLPOOL c6d32565925653050beb1939db6215ad910891a19ef721d6bc53b3d2beb50667f6201e5afc71e28c1644d18cdbdb6f2d53bfb5ca75feb9e129d01ed7fca035c1
+DIST simplejson-3.9.0.tar.gz 77211 SHA256 e9abeee37424f4bfcd27d001d943582fb8c729ffc0b74b72bd0e9b626ed0d1b6 SHA512 6c01d2b68a401719600eeb63704806da1eb0d79e7ee3486b6ab09d4fd0d5cb94a32b5865af2c090be4f109c967ddd223c7f7f7f8b070ec3d6b7afc7b888efe86 WHIRLPOOL 8c7ac5b4ee56e1aa8c8a79aaddd1db395405f45aa9717bee98c24d1d6c50a14570d26ab5c98b17608085c5607ff36875d8c3270a20087833fd6d4050029fac86
diff --git a/dev-python/simplejson/simplejson-3.9.0.ebuild b/dev-python/simplejson/simplejson-3.9.0.ebuild
new file mode 100644
index 000000000000..e47f3f11d14a
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="http://undefined.org/python/#simplejson https://pypi.python.org/pypi/simplejson"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ esetup.py test
+}