summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-12-24 20:23:42 +0100
committerDavide Pesavento <pesa@gentoo.org>2018-12-24 20:24:04 +0100
commitbe0fa350d2c3fca3b4a910d91769e856c1f726a0 (patch)
tree0cc2c91fb4ef4c8e9e370628e0958719771d1408 /dev-python/sip/sip-4.19.14_pre1812231555.ebuild
parentsys-fs/squashfs-tools: Version 4.3_p7 (diff)
downloadgentoo-be0fa350d2c3fca3b4a910d91769e856c1f726a0.tar.gz
gentoo-be0fa350d2c3fca3b4a910d91769e856c1f726a0.tar.bz2
gentoo-be0fa350d2c3fca3b4a910d91769e856c1f726a0.zip
dev-python/sip: drop live ebuild
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/sip/sip-4.19.14_pre1812231555.ebuild')
-rw-r--r--dev-python/sip/sip-4.19.14_pre1812231555.ebuild26
1 files changed, 3 insertions, 23 deletions
diff --git a/dev-python/sip/sip-4.19.14_pre1812231555.ebuild b/dev-python/sip/sip-4.19.14_pre1812231555.ebuild
index 461733f71a1f..69b050301a69 100644
--- a/dev-python/sip/sip-4.19.14_pre1812231555.ebuild
+++ b/dev-python/sip/sip-4.19.14_pre1812231555.ebuild
@@ -9,10 +9,7 @@ inherit python-r1 toolchain-funcs
DESCRIPTION="Python extension module generator for C and C++ libraries"
HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
-if [[ ${PV} == *9999 ]]; then
- inherit mercurial
- EHG_REPO_URI="https://www.riverbankcomputing.com/hg/sip"
-elif [[ ${PV} == *_pre* ]]; then
+if [[ ${PV} == *_pre* ]]; then
MY_P=${P/_pre/.dev}
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
S=${WORKDIR}/${MY_P}
@@ -26,31 +23,14 @@ LICENSE="|| ( GPL-2 GPL-3 SIP )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug doc"
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-if [[ ${PV} == *9999 ]]; then
- DEPEND+="
- sys-devel/bison
- sys-devel/flex
- doc? ( dev-python/sphinx[$(python_gen_usedep 'python2*')] )"
-fi
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-if [[ ${PV} == *9999 ]]; then
- REQUIRED_USE+=" || ( $(python_gen_useflags 'python2*') )"
-fi
PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
src_prepare() {
- if [[ ${PV} == *9999 ]]; then
- python_setup 'python2*'
- "${PYTHON}" build.py prepare || die
- if use doc; then
- "${PYTHON}" build.py doc || die
- fi
- fi
-
# Sub-slot sanity check
local sub_slot=${SLOT#*/}
local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h || die)