summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-20 16:41:20 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-06-08 21:15:10 +0200
commit77942a08e5dfba186e4a2a4a65f58e5b37829b9c (patch)
tree2ffbc19b63c49cf3feb4e1d93331dddbefb5e469 /dev-python/sip/sip-6.6.1.ebuild
parentnet-libs/libqrtr-glib: Add package, v1.2.2 (diff)
downloadgentoo-77942a08e5dfba186e4a2a4a65f58e5b37829b9c.tar.gz
gentoo-77942a08e5dfba186e4a2a4a65f58e5b37829b9c.tar.bz2
gentoo-77942a08e5dfba186e4a2a4a65f58e5b37829b9c.zip
dev-python/sip: add 6.6.1, enable py3.11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/sip/sip-6.6.1.ebuild')
-rw-r--r--dev-python/sip/sip-6.6.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sip/sip-6.6.1.ebuild b/dev-python/sip/sip-6.6.1.ebuild
new file mode 100644
index 000000000000..4e130e33eb13
--- /dev/null
+++ b/dev-python/sip/sip-6.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/ https://pypi.org/project/sip/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python311-invalid-regex.patch"
+ "${FILESDIR}/${PN}-6.5.0-pep517-args.patch"
+)
+
+distutils_enable_sphinx doc --no-autodoc