summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-01-22 19:45:29 +0100
committerDavide Pesavento <pesa@gentoo.org>2018-01-22 19:45:29 +0100
commit62d4c276445060eadf362de46ffc3dac371b3dc7 (patch)
tree905af4ca44678e5b61dec4f4eef5557483d3dbae /dev-python/sip
parentsys-process/systemd-cron: amd64 stable (diff)
downloadgentoo-62d4c276445060eadf362de46ffc3dac371b3dc7.tar.gz
gentoo-62d4c276445060eadf362de46ffc3dac371b3dc7.tar.bz2
gentoo-62d4c276445060eadf362de46ffc3dac371b3dc7.zip
dev-python/sip: remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-4.19.1.ebuild87
2 files changed, 0 insertions, 88 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 8c1e8964be3b..ff5a64ba4d50 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,2 @@
-DIST sip-4.19.1.tar.gz 1000644 BLAKE2B 7cb0362a60184ef4e5ba2b53d29c5ca70babd4e81f328beb24e7b3b7f27fc7a3aef3432a4ca599aad6833e088382ae2b705334dc2925b3c98d943cd6f88b1559 SHA512 fd98002117e9526f7f981b46362c41171e703a0e18e57112fcabf33d71fa13a4a091fdcb05c879ea721da59fa8c03087b8dc983fb2f832f764e5ad950c9bbecf
DIST sip-4.19.3.tar.gz 1007481 BLAKE2B cf4d53c956aa046f165e9ec05126fa9b6ca3df688b16ff79520da8ea82f7e9622e03448030db14b0d21ba090893375814f39d6b3fc62343880aa169c2680394f SHA512 b2dea0cb5e1b23531f35e94bd604ec9874f0875badb5b20eb5abd2732a1005b2dd15bb42e0007b65053a2153b50659f24671abd83a434991661168a5778b94bc
DIST sip-4.19.6.tar.gz 1019295 BLAKE2B 107bc63b8c0f200c292bbf465507602904383a1d3fd0b76da907cda2dcf0e79edb9cbf835bc15dbefd991db6a7eeff97462965d88704e3c926ce9e0dd5af829f SHA512 1bfd2da8b0ece6156aa94713d5e9ced6226b7f49427ca4a11b65452a67e9c740b93a1f90c00a0636d4eef8a31324988a84373c15194f64774b6f8c084d0464f7
diff --git a/dev-python/sip/sip-4.19.1.ebuild b/dev-python/sip/sip-4.19.1.ebuild
deleted file mode 100644
index 21a766bf9cda..000000000000
--- a/dev-python/sip/sip-4.19.1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit python-r1 toolchain-funcs
-
-DESCRIPTION="Python extension module generator for C and C++ libraries"
-HOMEPAGE="https://www.riverbankcomputing.com/software/sip/intro"
-SRC_URI="mirror://sourceforge/pyqt/${P}.tar.gz"
-
-# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
-SLOT="0/12"
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="debug doc"
-
-RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-4.18-darwin.patch )
-
-src_prepare() {
- # Sub-slot sanity check
- local sub_slot=${SLOT#*/}
- local sip_api_major_nr=$(sed -nre 's:^#define SIP_API_MAJOR_NR\s+([0-9]+):\1:p' siplib/sip.h.in)
- if [[ ${sub_slot} != ${sip_api_major_nr} ]]; then
- eerror
- eerror "Ebuild sub-slot (${sub_slot}) does not match SIP_API_MAJOR_NR (${sip_api_major_nr})"
- eerror "Please update SLOT variable as follows:"
- eerror " SLOT=\"${SLOT%%/*}/${sip_api_major_nr}\""
- eerror
- die "sub-slot sanity check failed"
- fi
-
- default
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}"
- "${S}"/configure.py
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --incdir="$(python_get_includedir)"
- $(usex debug --debug '')
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
- }
- python_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- emake DESTDIR="${D}" install
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- einstalldocs
- use doc && dodoc -r doc/html
-}