summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-30 08:24:40 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-30 08:24:40 +0100
commit051dbce592efbbe452528d2572e85806e89b8529 (patch)
tree8593d0a815419e7867526c406e0650f76a63687a /dev-python/six
parentdev-ruby/nokogiri: add 1.6.7 (diff)
downloadgentoo-051dbce592efbbe452528d2572e85806e89b8529.tar.gz
gentoo-051dbce592efbbe452528d2572e85806e89b8529.tar.bz2
gentoo-051dbce592efbbe452528d2572e85806e89b8529.zip
dev-python/six: Run six dir QA check twice
Using pkg_pretend to catch as early as possible but don't break when python impl is not installed. Use pkg_Setup to catch them all Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index 6161e0ad2ca7..ffbb168d3c24 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,9 +26,23 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
+# Run twice.
+# pkg_pretend to catch as early as possible, but be forgiving if
+# python impl is not installed allready.
+# pkg_setup to catch them all
pkg_pretend() {
six_dir_check() {
local dir="${ROOT}"/$(python_get_sitedir)/six
+ type -p "${PYTHON}" > /dev/null || return 0
+ [[ -d "${dir}" ]] \
+ && die "${PN} doesn't work if ${dir} is a directory #546730"
+ }
+ python_foreach_impl six_dir_check
+}
+
+pkg_setup() {
+ six_dir_check() {
+ local dir="${ROOT}"/$(python_get_sitedir)/six
[[ -d "${dir}" ]] \
&& die "${PN} doesn't work if ${dir} is a directory #546730"
}