summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2015-12-28 11:27:15 -0500
committerMike Gilbert <floppym@gentoo.org>2015-12-28 11:27:19 -0500
commitee672ed083b9ef11353088e6b6252c28404d38c7 (patch)
treef745282f61232012ea915443e0477a90cbd2f4c4 /dev-python/six
parentdev-perl/AnyEvent: alpha/amd64/arm/ia64/ppc/sparc/x86 stable, (ALLARCHES poli... (diff)
downloadgentoo-ee672ed083b9ef11353088e6b6252c28404d38c7.tar.gz
gentoo-ee672ed083b9ef11353088e6b6252c28404d38c7.tar.bz2
gentoo-ee672ed083b9ef11353088e6b6252c28404d38c7.zip
dev-python/six: Remove pkg_setup check
Running python_foreach_impl from pkg_setup causes more problems than it is worth. Bug: https://bugs.gentoo.org/569962 Package-Manager: portage-2.2.26_p32
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.10.0.ebuild10
1 files changed, 0 insertions, 10 deletions
diff --git a/dev-python/six/six-1.10.0.ebuild b/dev-python/six/six-1.10.0.ebuild
index b00b76cf9777..cb6a767b3815 100644
--- a/dev-python/six/six-1.10.0.ebuild
+++ b/dev-python/six/six-1.10.0.ebuild
@@ -26,16 +26,6 @@ PATCHES=(
"${FILESDIR}"/1.9.0-mapping.patch
)
-pkg_setup() {
- six_dir_check() {
- local dir="${ROOT%/}$(python_get_sitedir)"/six
- if [[ -d "${dir}" ]]; then
- die "${PN} doesn't work if ${dir} is a directory #546730"
- fi
- }
- python_foreach_impl six_dir_check
-}
-
python_prepare_all() {
# https://bitbucket.org/gutworth/six/issues/139/
sed \