summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-06-15 20:32:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-06-16 22:01:58 +0200
commitb230470817f44c9f2c8fcae628e93997f815fa43 (patch)
tree2741a65a48c4a3fd27ec7702fcd75c40eb4600f1 /dev-python/slackclient/slackclient-1.2.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.9.109 (diff)
downloadgentoo-b230470817f44c9f2c8fcae628e93997f815fa43.tar.gz
gentoo-b230470817f44c9f2c8fcae628e93997f815fa43.tar.bz2
gentoo-b230470817f44c9f2c8fcae628e93997f815fa43.zip
dev-python/slackclient: version bump.
Closes: https://bugs.gentoo.org/651138 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/slackclient/slackclient-1.2.0.ebuild')
-rw-r--r--dev-python/slackclient/slackclient-1.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/slackclient/slackclient-1.2.0.ebuild b/dev-python/slackclient/slackclient-1.2.0.ebuild
new file mode 100644
index 000000000000..728b06056bd2
--- /dev/null
+++ b/dev-python/slackclient/slackclient-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="Client for Slack supporting the Slack Web and Real Time Messaging API"
+HOMEPAGE="https://github.com/slackapi/python-slackclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/websocket-client-0.35[${PYTHON_USEDEP}]
+ <dev-python/websocket-client-1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.11[${PYTHON_USEDEP}]
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${RDEPEND}"