summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sleekxmpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sleekxmpp')
-rw-r--r--dev-python/sleekxmpp/Manifest2
-rw-r--r--dev-python/sleekxmpp/metadata.xml8
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-1.3.0.ebuild29
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-1.3.1.ebuild29
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/sleekxmpp/Manifest b/dev-python/sleekxmpp/Manifest
new file mode 100644
index 000000000000..26d6fd4b66bd
--- /dev/null
+++ b/dev-python/sleekxmpp/Manifest
@@ -0,0 +1,2 @@
+DIST sleekxmpp-1.3.0.tar.gz 1013915 SHA256 1665b42ed489c7f0411b466172b72752a6caeeb19310314763b447d9a31980e8 SHA512 e48a9b8da8bfbcd97ed372b7fafab82727851f1b1a09870c652dbbdbd6d529d6da26c5778e3d23e2f67aa837713ac14475f9c2cbca708153c3d06960e8cbe53b WHIRLPOOL c7e8a771f015f8f1adfa1e15f4799d55d9590db668a8ddd10065353a793ea93dabe1b8f921d31246934d57de24fad12692ec7fbdecf505116efd618fa4c4a078
+DIST sleekxmpp-1.3.1.tar.gz 1014004 SHA256 72f2887ccb29bd53f9bbf09225274d11d75e88507ea3ddee97cef0b289bcb04f SHA512 1f3c68672536da0d20cd8717f7835096003019f03a05fb08ce87f784b0636d781aa78691ee54927d4755e71a57956972af0a653deb6eff0f7eb16b9a236baa65 WHIRLPOOL 464de44bff78c294d35c01b89319b82bb6f782269c0b880ddb2692b85b0e05ed5ab47e0acb3476187c10440f3bb77f1487f6795a6a08dd6f34cdcfdf8a5ff6cb
diff --git a/dev-python/sleekxmpp/metadata.xml b/dev-python/sleekxmpp/metadata.xml
new file mode 100644
index 000000000000..e75375bafac9
--- /dev/null
+++ b/dev-python/sleekxmpp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="github">fritzy/SleekXMPP</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sleekxmpp/sleekxmpp-1.3.0.ebuild b/dev-python/sleekxmpp/sleekxmpp-1.3.0.ebuild
new file mode 100644
index 000000000000..e92474c9ed19
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit eutils distutils-r1
+
+MY_PN=SleekXMPP
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python library for XMPP"
+HOMEPAGE="http://sleekxmpp.com/ https://github.com/fritzy/SleekXMPP/"
+SRC_URI="https://github.com/fritzy/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/sleekxmpp/sleekxmpp-1.3.1.ebuild b/dev-python/sleekxmpp/sleekxmpp-1.3.1.ebuild
new file mode 100644
index 000000000000..67b298a0d5d1
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-1.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit eutils distutils-r1
+
+MY_PN=SleekXMPP
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python library for XMPP"
+HOMEPAGE="http://sleekxmpp.com/ https://github.com/fritzy/SleekXMPP/"
+SRC_URI="https://github.com/fritzy/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="crypt? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ esetup.py test
+}