summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2018-08-18 17:39:02 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2018-08-18 20:53:21 +0100
commit36e6b308737eb60bfce0ea8bd78ebc2a16204ffb (patch)
tree803a5898800941f0c02c11b4696e4abfeb98349b /dev-python/slixmpp
parentsys-block/storcli: bump to v007.0606.0000.0000 (diff)
downloadgentoo-36e6b308737eb60bfce0ea8bd78ebc2a16204ffb.tar.gz
gentoo-36e6b308737eb60bfce0ea8bd78ebc2a16204ffb.tar.bz2
gentoo-36e6b308737eb60bfce0ea8bd78ebc2a16204ffb.zip
dev-python/slixmpp: add new package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/slixmpp')
-rw-r--r--dev-python/slixmpp/Manifest1
-rw-r--r--dev-python/slixmpp/metadata.xml11
-rw-r--r--dev-python/slixmpp/slixmpp-1.4.0.ebuild36
-rw-r--r--dev-python/slixmpp/slixmpp-9999.ebuild36
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
new file mode 100644
index 000000000000..bf08c4b528bc
--- /dev/null
+++ b/dev-python/slixmpp/Manifest
@@ -0,0 +1 @@
+DIST slixmpp-1.4.0.tar.gz 862826 BLAKE2B 940c6c66f7f98574c88da6fbfaadf7103c4469cd198e096fbad57978f5e206c53b86933a930a24a8b891415b961c4a255d4c9c25885a8bd630f5d6185486fb6e SHA512 586fa5156641d786f9e45df8e6a1a20b8cb2dc2b9baef2a0713daa9ab8a3321202fd4b31d5753cf2659cc9311a4842bee9991a7fc295e62dfd78a869d8619d20
diff --git a/dev-python/slixmpp/metadata.xml b/dev-python/slixmpp/metadata.xml
new file mode 100644
index 000000000000..97309be0a01b
--- /dev/null
+++ b/dev-python/slixmpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">slixmpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/slixmpp/slixmpp-1.4.0.ebuild b/dev-python/slixmpp/slixmpp-1.4.0.ebuild
new file mode 100644
index 000000000000..be8cfcfecb51
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-1.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/slixmpp/slixmpp-9999.ebuild b/dev-python/slixmpp/slixmpp-9999.ebuild
new file mode 100644
index 000000000000..be8cfcfecb51
--- /dev/null
+++ b/dev-python/slixmpp/slixmpp-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Python 3 library for XMPP"
+HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+ dev-python/aiodns[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-dns/libidn
+ test? ( $RDEPEND )
+"
+
+python_test() {
+ esetup.py test
+}