summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-05-14 01:29:30 -0700
committerZac Medico <zmedico@gentoo.org>2017-05-14 02:29:28 -0700
commit49c4bbb2604de2cbda3017cb879df3c7c3f21272 (patch)
tree000994eda01b9c81f51cbc9afde17d631543a249 /dev-python/snakeoil/snakeoil-0.7.1.ebuild
parentdev-lang/vala: bump to 0.34.8 (diff)
downloadgentoo-49c4bbb2604de2cbda3017cb879df3c7c3f21272.tar.gz
gentoo-49c4bbb2604de2cbda3017cb879df3c7c3f21272.tar.bz2
gentoo-49c4bbb2604de2cbda3017cb879df3c7c3f21272.zip
dev-python/snakeoil: Add python3.6 to PYTHON_COMPAT
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/snakeoil/snakeoil-0.7.1.ebuild')
-rw-r--r--dev-python/snakeoil/snakeoil-0.7.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/snakeoil/snakeoil-0.7.1.ebuild b/dev-python/snakeoil/snakeoil-0.7.1.ebuild
index c5e27b4fbea1..080b0c89c380 100644
--- a/dev-python/snakeoil/snakeoil-0.7.1.ebuild
+++ b/dev-python/snakeoil/snakeoil-0.7.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -22,6 +22,10 @@ SLOT="0"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+PATCHES=(
+ "${FILESDIR}/${P}-test.patch"
+)
+
python_configure_all() {
# disable snakeoil 2to3 caching
unset PY2TO3_CACHEDIR