summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 11:01:27 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 11:57:58 +0100
commit53b661af538f955d0827467c09e2d7c4ffc49707 (patch)
tree3a07163305f34e85f63ddcf431403633b7117546 /dev-python/snakeoil
parentwww-client/vivaldi: Add version 3.6.2165.34 (diff)
downloadgentoo-53b661af538f955d0827467c09e2d7c4ffc49707.tar.gz
gentoo-53b661af538f955d0827467c09e2d7c4ffc49707.tar.bz2
gentoo-53b661af538f955d0827467c09e2d7c4ffc49707.zip
dev-python/snakeoil: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.9.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 249e4f1bdabb..4e5fc9c10b98 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,2 +1,3 @@
DIST snakeoil-0.8.8.tar.gz 296519 BLAKE2B 5a5f6326d01874b46a5cb85f5370217f4f3dfd5743679280f1f59737567cd5d79deb945be847fd3cd47ff0ed67cc836d2a3e53c4aefbe8080da767f380295538 SHA512 ea1ff6ea45c9f5fc3bc539cc65031050093cc1fbdda869b7160b286dcf3233577ca297ab55ee3d7ee4253c5485f9e956e14ee2a97bfb88680811d1b8af6cd62d
DIST snakeoil-0.8.9.tar.gz 271205 BLAKE2B dcaf4d26b430a2e99481182aa912a884a0cf5943f65028f4da098ec1b0ab177a97aeb0743d90cade589eba598598eccd275b15379d281ad0dc0bf62badd24c55 SHA512 d80f4c5be5d97598a119bd29413df1960487e4af2532b33b03c17337d15d24b34c4e5617f0d5d40db973f009697de25ae8c5bf5e60c19409835b3e77b4ffb461
+DIST snakeoil-0.9.0.tar.gz 271675 BLAKE2B 7dd65335fd79a7d335e5047ba928d7c156c5758874e20e41a06fc25fd2133697bccadc3cd24bcd611b7b210dfe330c121487c6d5bf5afa6330b714c928f3fd44 SHA512 c34938fdc5dd41ab84c5775090cc6bac1ac6bf0bd145c8d8966582917205ef422da272d12e4272afde764f52c62c8f02be076ce13c6552e0384a18fc8442cf96
diff --git a/dev-python/snakeoil/snakeoil-0.9.0.ebuild b/dev-python/snakeoil/snakeoil-0.9.0.ebuild
new file mode 100644
index 000000000000..17c7a024b1f0
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}