summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-31 22:32:38 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-31 22:36:47 +0100
commitb1643db8fa8b66be507f409a92bff86953dbcfcd (patch)
tree047c1d93e296d70d0ce313e9108f8efbb6c9a437 /dev-python/snakeoil
parentgui-libs/display-manager-init: add postinst warning (diff)
downloadgentoo-b1643db8fa8b66be507f409a92bff86953dbcfcd.tar.gz
gentoo-b1643db8fa8b66be507f409a92bff86953dbcfcd.tar.bz2
gentoo-b1643db8fa8b66be507f409a92bff86953dbcfcd.zip
dev-python/snakeoil: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.9.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 4e5fc9c10b98..81c2ae07a651 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1,3 +1,4 @@
DIST snakeoil-0.8.8.tar.gz 296519 BLAKE2B 5a5f6326d01874b46a5cb85f5370217f4f3dfd5743679280f1f59737567cd5d79deb945be847fd3cd47ff0ed67cc836d2a3e53c4aefbe8080da767f380295538 SHA512 ea1ff6ea45c9f5fc3bc539cc65031050093cc1fbdda869b7160b286dcf3233577ca297ab55ee3d7ee4253c5485f9e956e14ee2a97bfb88680811d1b8af6cd62d
DIST snakeoil-0.8.9.tar.gz 271205 BLAKE2B dcaf4d26b430a2e99481182aa912a884a0cf5943f65028f4da098ec1b0ab177a97aeb0743d90cade589eba598598eccd275b15379d281ad0dc0bf62badd24c55 SHA512 d80f4c5be5d97598a119bd29413df1960487e4af2532b33b03c17337d15d24b34c4e5617f0d5d40db973f009697de25ae8c5bf5e60c19409835b3e77b4ffb461
DIST snakeoil-0.9.0.tar.gz 271675 BLAKE2B 7dd65335fd79a7d335e5047ba928d7c156c5758874e20e41a06fc25fd2133697bccadc3cd24bcd611b7b210dfe330c121487c6d5bf5afa6330b714c928f3fd44 SHA512 c34938fdc5dd41ab84c5775090cc6bac1ac6bf0bd145c8d8966582917205ef422da272d12e4272afde764f52c62c8f02be076ce13c6552e0384a18fc8442cf96
+DIST snakeoil-0.9.1.tar.gz 271045 BLAKE2B 74c45d38d294e06940d4a339e6d6c6e66d84b7fd174b4d79a9716262bc1902d47dfed1751b44183f9119ccb3bd50e11700951d15070a15b94d6a7b20f77c5919 SHA512 94d8baed4baaab8c3cb3631fed4e6cced8fa32c953bba2ec2afd0cc99eb9b526dc58e5e9efb402513b0416cda21a0811b14a2a98044fd1d5bb7f6f2b349db24a
diff --git a/dev-python/snakeoil/snakeoil-0.9.1.ebuild b/dev-python/snakeoil/snakeoil-0.9.1.ebuild
new file mode 100644
index 000000000000..0a7822decd00
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] && BDEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest