summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-12-04 22:49:57 -0700
committerTim Harder <radhermit@gentoo.org>2020-12-05 00:14:02 -0700
commite8e39f230f9f14351e6576d4130c13bdd6d7d1a8 (patch)
tree9b2d58af9017df6ff0d94700a378c76e7d1ee67b /dev-python/snakeoil
parentprofiles/powerpc: Stable-mask media-libs/mesa[vulkan,zink] (diff)
downloadgentoo-e8e39f230f9f14351e6576d4130c13bdd6d7d1a8.tar.gz
gentoo-e8e39f230f9f14351e6576d4130c13bdd6d7d1a8.tar.bz2
gentoo-e8e39f230f9f14351e6576d4130c13bdd6d7d1a8.zip
dev-python/snakeoil: version bump to 0.8.9
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/snakeoil')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.8.9.ebuild32
-rw-r--r--dev-python/snakeoil/snakeoil-9999.ebuild2
3 files changed, 34 insertions, 1 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index aab9191ed999..249e4f1bdabb 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1 +1,2 @@
DIST snakeoil-0.8.8.tar.gz 296519 BLAKE2B 5a5f6326d01874b46a5cb85f5370217f4f3dfd5743679280f1f59737567cd5d79deb945be847fd3cd47ff0ed67cc836d2a3e53c4aefbe8080da767f380295538 SHA512 ea1ff6ea45c9f5fc3bc539cc65031050093cc1fbdda869b7160b286dcf3233577ca297ab55ee3d7ee4253c5485f9e956e14ee2a97bfb88680811d1b8af6cd62d
+DIST snakeoil-0.8.9.tar.gz 271205 BLAKE2B dcaf4d26b430a2e99481182aa912a884a0cf5943f65028f4da098ec1b0ab177a97aeb0743d90cade589eba598598eccd275b15379d281ad0dc0bf62badd24c55 SHA512 d80f4c5be5d97598a119bd29413df1960487e4af2532b33b03c17337d15d24b34c4e5617f0d5d40db973f009697de25ae8c5bf5e60c19409835b3e77b4ffb461
diff --git a/dev-python/snakeoil/snakeoil-0.8.9.ebuild b/dev-python/snakeoil/snakeoil-0.8.9.ebuild
new file mode 100644
index 000000000000..c9ce0b8837a5
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.8.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+[[ ${PV} == 9999 ]] && DEPEND+=" dev-python/cython[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/snakeoil/snakeoil-9999.ebuild b/dev-python/snakeoil/snakeoil-9999.ebuild
index 68c9d1509604..c9ce0b8837a5 100644
--- a/dev-python/snakeoil/snakeoil-9999.ebuild
+++ b/dev-python/snakeoil/snakeoil-9999.ebuild
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi