summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-08 13:37:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-05-09 13:35:15 +0200
commit5c94382a6b3bb024cf0f6a0a4ca17bad373c9341 (patch)
treec12d88babf6ef88d6058069bb780cddbee71b0e2 /dev-python/sniffio
parentdev-python/sniffio: Update metadata (diff)
downloadgentoo-5c94382a6b3bb024cf0f6a0a4ca17bad373c9341.tar.gz
gentoo-5c94382a6b3bb024cf0f6a0a4ca17bad373c9341.tar.bz2
gentoo-5c94382a6b3bb024cf0f6a0a4ca17bad373c9341.zip
dev-python/sniffio: Port to python3.10
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
index 89f3dc32585e..ea9fbac068cb 100644
--- a/dev-python/sniffio/sniffio-1.2.0.ebuild
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Sniff out which async library your code is running under"
@@ -26,6 +26,5 @@ python_test() {
sniffio/_tests/test_sniffio.py::test_curio
)
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests failed with ${EPYTHON}"
+ epytest ${deselect[@]/#/--deselect }
}