summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-26 18:53:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-26 18:53:25 +0200
commitdf8be6039db0b088983988434180b7dcf0e654ba (patch)
tree55e46fcfeeee161247b77637171933224864e240 /dev-python/soupsieve
parentdev-python/u-msgpack: Bump to 2.6.0 (diff)
downloadgentoo-df8be6039db0b088983988434180b7dcf0e654ba.tar.gz
gentoo-df8be6039db0b088983988434180b7dcf0e654ba.tar.bz2
gentoo-df8be6039db0b088983988434180b7dcf0e654ba.zip
dev-python/soupsieve: Bump to 1.9.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/soupsieve')
-rw-r--r--dev-python/soupsieve/Manifest1
-rw-r--r--dev-python/soupsieve/soupsieve-1.9.6.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/soupsieve/Manifest b/dev-python/soupsieve/Manifest
index 9facd4bb0ed6..c68b2d46074d 100644
--- a/dev-python/soupsieve/Manifest
+++ b/dev-python/soupsieve/Manifest
@@ -1 +1,2 @@
DIST soupsieve-1.9.5.tar.gz 99119 BLAKE2B adf2f068ca536583557dff5b86fbb8020de8139c346ab124c8f78d91d2c0db49553cc9b8580a4e8af0fb74e19a8f8b6e5459b654a900034d76a677e60ea0fece SHA512 38cf37c7080ec6054291a076eb4b152bbf5267b9fed25f933a340345cd7807f14f4a5300707090fd233382e96841f6a33305876cf02740c96dd6aa9d2af06868
+DIST soupsieve-1.9.6.tar.gz 99276 BLAKE2B 2bd2f74e6974ad73c79c018f704fef600594c568471062c503a7fb1248e2cc1840011d31550f7573654f015016f0d3272778b0100e4701318a829f916f06698e SHA512 44954cdedc16a51c794ebe6770caeb8f179167ad2f0a0478cb1efd5878d6cc49fffd6119125964b19184afa6d0d7dedadb81dee020a48c5128ccf56e36a78f61
diff --git a/dev-python/soupsieve/soupsieve-1.9.6.ebuild b/dev-python/soupsieve/soupsieve-1.9.6.ebuild
new file mode 100644
index 000000000000..0c8916942a87
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-1.9.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="https://github.com/facelessuser/soupsieve
+ https://pypi.python.org/pypi/soupsieve"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT+=" !test? ( test )"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/backports-functools-lru-cache[${PYTHON_USEDEP}]' -2)
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]' python2_7 'python3*')
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest