summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 11:36:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 11:36:07 +0200
commitff9ab2c9638af8c33ba92409d1e4613e2e35dafd (patch)
treedec8d26982c544910b6d1c5c488d04c0483a00a7 /dev-python/soupsieve
parentdistutils-r1.eclass: Add hatchling support (meh!) (diff)
downloadgentoo-ff9ab2c9638af8c33ba92409d1e4613e2e35dafd.tar.gz
gentoo-ff9ab2c9638af8c33ba92409d1e4613e2e35dafd.tar.bz2
gentoo-ff9ab2c9638af8c33ba92409d1e4613e2e35dafd.zip
dev-python/soupsieve: Bump to 2.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/soupsieve')
-rw-r--r--dev-python/soupsieve/Manifest1
-rw-r--r--dev-python/soupsieve/soupsieve-2.3.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/soupsieve/Manifest b/dev-python/soupsieve/Manifest
index 813b5593a5fe..8978edcc785f 100644
--- a/dev-python/soupsieve/Manifest
+++ b/dev-python/soupsieve/Manifest
@@ -1 +1,2 @@
DIST soupsieve-2.3.1.tar.gz 104251 BLAKE2B c395b8dc0944457d6c5f217a03c6fc5f3895868a629eb72d86733fb0d9c6b1d1c41a2e035d5118c9c6fcc6a22e9ff79b9de8417131d30bbc6e1ba02c813ced56 SHA512 3f1245b27d67e8b37bce4cb0b21b2b3f4d6b7ae112cc66672e5406c0701b28e605ed12db1e111bfeccea15625b17042e398b075b7f026d3f3e15069f0cafccac
+DIST soupsieve-2.3.2.tar.gz 103869 BLAKE2B 0820f3935aaf0bda436abf10ddb0d64d6b2de99d116fdc84518879ca468688918a0995f4666e04d4892fee4d221b2d6a843f200c4bf05c3bf5755004a3fbb7ec SHA512 a91c453098697d0b6120e80dd2cf56ec0359d9d3d98ef54e348e8f9832b3b70626fcdc7c21bc3abe0fba32a83cc62d05b750f2d2fa79261479bf89c0aa782caa
diff --git a/dev-python/soupsieve/soupsieve-2.3.2.ebuild b/dev-python/soupsieve/soupsieve-2.3.2.ebuild
new file mode 100644
index 000000000000..1447e0c4dd37
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-2.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="
+ https://github.com/facelessuser/soupsieve/
+ https://pypi.org/project/soupsieve/
+"
+SRC_URI="
+ https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest