summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 10:07:43 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:04 +0200
commit152d3262604936a5cfa699583f8a13792e4e97ad (patch)
tree456c342d992b8c77b7e33e7d2556797a4ccfe60f /dev-python/sphinx-aiohttp-theme
parentdev-python/sphinxcontrib-asyncio: Enable Python 3.7 (diff)
downloadgentoo-152d3262604936a5cfa699583f8a13792e4e97ad.tar.gz
gentoo-152d3262604936a5cfa699583f8a13792e4e97ad.tar.bz2
gentoo-152d3262604936a5cfa699583f8a13792e4e97ad.zip
dev-python/sphinx-aiohttp-theme: Bump to 0.1.5, EAPI=7, Py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-aiohttp-theme')
-rw-r--r--dev-python/sphinx-aiohttp-theme/Manifest1
-rw-r--r--dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/sphinx-aiohttp-theme/Manifest b/dev-python/sphinx-aiohttp-theme/Manifest
index 03d16a6d9ccf..090340387646 100644
--- a/dev-python/sphinx-aiohttp-theme/Manifest
+++ b/dev-python/sphinx-aiohttp-theme/Manifest
@@ -1 +1,2 @@
DIST aiohttp-theme-0.1.4.tar.gz 10723 BLAKE2B afc398bb65e69fcc931f214c613f789da07c89bafd26ff207d4c5666edbe323f77c4a6fec09817d4dc6bb1d40e21ddd82f0b7b5c25dc5fe89b8b83c1c423bad7 SHA512 b487c9095a677baf9471b93be5b9cc3a697f62d2674d27ea4a7aee043e5dd75c5543a0e0a2e51c28e36e5bbf324bcb6d06786b31ae3b492ad2f972c6776c40af
+DIST aiohttp-theme-0.1.5.tar.gz 11132 BLAKE2B e405d3a3ccc0d8568ecc42f8891eebe405d2d75cd47e60910f59ebc979da07362d3cbc20833412a462454b2703aa945f491e85c10b206a356545a13cbc07984a SHA512 106a77665d907c45db1fc2c23990eab61cc70f9f373ce7fe0d231f9744efe5dc7119606bcbdf558ceb038edd7e0cb955531fd74c496923038bcfd799bf67616c
diff --git a/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.5.ebuild b/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.5.ebuild
new file mode 100644
index 000000000000..b6446239067b
--- /dev/null
+++ b/dev-python/sphinx-aiohttp-theme/sphinx-aiohttp-theme-0.1.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN#sphinx-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Sphinx theme for aiohttp"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-theme"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"