summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-11 09:10:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-11 09:10:43 +0200
commit256a1cb015ad4a722589bedec6f4bf0acf277c29 (patch)
treea9cb7819e37e3ba3cec0a576f8435c42dde85c62 /dev-python/sphinx-prompt
parentdev-python/xlsxwriter: Bump to 3.0.1 (diff)
downloadgentoo-256a1cb015ad4a722589bedec6f4bf0acf277c29.tar.gz
gentoo-256a1cb015ad4a722589bedec6f4bf0acf277c29.tar.bz2
gentoo-256a1cb015ad4a722589bedec6f4bf0acf277c29.zip
dev-python/sphinx-prompt: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-prompt')
-rw-r--r--dev-python/sphinx-prompt/Manifest1
-rw-r--r--dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sphinx-prompt/Manifest b/dev-python/sphinx-prompt/Manifest
index 4ce92bdad848..8e72444e278a 100644
--- a/dev-python/sphinx-prompt/Manifest
+++ b/dev-python/sphinx-prompt/Manifest
@@ -1 +1,2 @@
DIST sphinx-prompt-1.4.0.tar.gz 9072 BLAKE2B c3ee936bb05eb39fcabd85260ef65b66c9a3fbf64d1b1e188ba889a3777d32fd90c6857d88191f5d9521b25ae46bc6ffc1777c18ace7e0aa0d96f266548ae7be SHA512 e79deb7164fe76f5f4a82855030d5eadd1966d87c0785d2a7a743205301ae0809398823e2a3558c3759774b3ee38c974638daf0b58ce565ef5b298f593ffd18d
+DIST sphinx-prompt-1.5.0.tar.gz 21537 BLAKE2B a5bc69797ea526bc3d66b52e98b80cbb9958add084ea6a4d70a85cc06c69271bbe9e658eb517b78dd758178b6f3b93d92ea87e9432e5c28a61307706a3c34ee8 SHA512 b3d023388eb024303e9264e621ad379367916f8e3567192fde90b3f0d96c94c53d783c2e14970ad3d85895053b3aab9ece6d9573d3bab1dc894e0e04757f3a40
diff --git a/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild b/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild
new file mode 100644
index 000000000000..ece6135668ec
--- /dev/null
+++ b/dev-python/sphinx-prompt/sphinx-prompt-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Sphinx directive to add unselectable prompt"
+HOMEPAGE="https://github.com/sbrunner/sphinx-prompt/"
+SRC_URI="https://github.com/sbrunner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest