summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 18:37:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 19:17:07 +0200
commitbdf49b490fdba7babab3b1a8f4b6f67bbc8fe79c (patch)
treea8a6f70f680bcc9b467aba4a099b449277d132f1 /dev-python/sphinx
parentdev-python/sphinxcontrib-websupport: Port to py39 (diff)
downloadgentoo-bdf49b490fdba7babab3b1a8f4b6f67bbc8fe79c.tar.gz
gentoo-bdf49b490fdba7babab3b1a8f4b6f67bbc8fe79c.tar.bz2
gentoo-bdf49b490fdba7babab3b1a8f4b6f67bbc8fe79c.zip
dev-python/sphinx: Port to py39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/sphinx-3.0.4.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/sphinx/sphinx-3.0.4.ebuild b/dev-python/sphinx/sphinx-3.0.4.ebuild
index 3154c9ce95ac..643691ef8cbd 100644
--- a/dev-python/sphinx/sphinx-3.0.4.ebuild
+++ b/dev-python/sphinx/sphinx-3.0.4.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -44,13 +44,13 @@ RDEPEND="
dev-texlive/texlive-luatex
app-text/dvipng
)"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
doc? (
dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
media-gfx/graphviz
)
test? (
+ ${RDEPEND}
dev-python/html5lib[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
virtual/imagemagick-tools[jpeg,png,svg]