summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-08 15:42:14 +0100
committerZac Medico <zmedico@gentoo.org>2020-11-08 14:28:13 -0800
commit29270cde6cac9f01d6fe17b88f5f1f89c470fd63 (patch)
treeec2b2dffc9bfd09aced446b16c30423d2c873cbb /dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
parentdev-python/vine: add python3_9 (diff)
downloadgentoo-29270cde6cac9f01d6fe17b88f5f1f89c470fd63.tar.gz
gentoo-29270cde6cac9f01d6fe17b88f5f1f89c470fd63.tar.bz2
gentoo-29270cde6cac9f01d6fe17b88f5f1f89c470fd63.zip
dev-python/sphinx_celery: add python3_9, fix DISTUTILS_USE_SETUPTOOLS
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild')
-rw-r--r--dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild b/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
index 44b953238ab4..c8c72c46f793 100644
--- a/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
+++ b/dev-python/sphinx_celery/sphinx_celery-2.0.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -14,6 +15,5 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/sphinx-2.0.0[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/sphinx-2.0.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"