summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-07-30 09:55:08 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-07-30 09:55:08 -0500
commite453c0eedbbd14f686945ee29b0374162c3ac99c (patch)
tree764d84180a34021d0279f51a29ce39f748100e6b /dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild
parentsys-kernel/pf-sources: fix overlong DESCRIPTION (diff)
downloadgentoo-e453c0eedbbd14f686945ee29b0374162c3ac99c.tar.gz
gentoo-e453c0eedbbd14f686945ee29b0374162c3ac99c.tar.bz2
gentoo-e453c0eedbbd14f686945ee29b0374162c3ac99c.zip
dev-python/sphinxcontrib-asyncio: add version 0.2.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild')
-rw-r--r--dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild
new file mode 100644
index 000000000000..a7573f4c2fb4
--- /dev/null
+++ b/dev-python/sphinxcontrib-asyncio/sphinxcontrib-asyncio-0.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+inherit distutils-r1
+
+DESCRIPTION="sphinx extension to support coroutines in markup"
+HOMEPAGE="https://github.com/aio-libs/sphinxcontrib-asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ ${PYTHON} -m pytest tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}