summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-10 23:04:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-10 23:20:13 +0200
commit955914db6c97ce5e0bc4889efe57f36a00b2d1ab (patch)
tree7f152046c4def33ff45110fbae0ee87fc9cbc4ca /dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.2.ebuild
parentdev-python/hypothesis: Bump to 6.42.3 (diff)
downloadgentoo-955914db6c97ce5e0bc4889efe57f36a00b2d1ab.tar.gz
gentoo-955914db6c97ce5e0bc4889efe57f36a00b2d1ab.tar.bz2
gentoo-955914db6c97ce5e0bc4889efe57f36a00b2d1ab.zip
dev-python/sphinxcontrib-bibtex: Bump to 2.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.2.ebuild')
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.2.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.2.ebuild
new file mode 100644
index 000000000000..05db93750374
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="https://github.com/mcmtroffaes/sphinxcontrib-bibtex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/pybtex-0.24[${PYTHON_USEDEP}]
+ dev-python/pybtex-docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ # this is needed to keep the tests working while
+ # dev-python/namespace-sphinxcontrib is still installed
+ cat > "${BUILD_DIR}/install$(python_get_sitedir)/sphinxcontrib/__init__.py" <<-EOF || die
+ __path__ = __import__('pkgutil').extend_path(__path__, __name__)
+ EOF
+ epytest
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/sphinxcontrib/__init__.py" || die
+}